[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[GNUnet-developers] Electric fence library (and more gtk)

From: Tom Barnes-Lawrence
Subject: [GNUnet-developers] Electric fence library (and more gtk)
Date: Wed, 22 Jan 2003 05:43:52 +0000
User-agent: Mutt/1.3.28i

Hi again,
 In recompiling GNUnet (Yes, OK, I admit it, I'm only just applying the
0.5.0b patch. Sorry.), I thought I'd try some of the options for
debugging libraries. I chose electric fence.

 After a lot of mucking about (partly because GNUnet's requirements
seem to have advanced since last time), I had it all installed, but
found that whenever I started gnunetd, it would give the message
about electric fence, it would leave the .pid file in the .gnunet
directory, and it would look like it had forked into the background...

...but on closer inspection, the process would not be there whenever
I ran ps ax! I tried this several times, trying things like starting
in my home directory, deleting the PID file first, but it seemed
it wasn't going to work.

In the end, I tried compiling without electric fence, and it is
working now.

Changing the subject to the GUI again, I'm now getting mixed results
from gnunet-gtk: I've got *one* client running that has several search
tabs on it and responses in some of them, and it's running -but has
the issue that it's not selecting DOWNLOADDIR from the config file
to be the default directory to save to (and being GTK, it has that
stupid problem with deleting the filename when you try to change
directory). And hey, hows that- when you cancel saving the file
because the dialogue box's eaten the filename, the list doesn't
then show that file anymore!

Whereas, it seems every *other* time I start a copy of gnunet-gtk,
it shows the behaviour I'm used to: It segfaults as soon as a search
response appears (hence keywords that have responses cached locally
seem to make the program crash immediately).

Actually, I've now got a second surviving gnunet-gtk.

Aha! Here is a little hypothesis: If the *first* thing you search for
returns no responses, responses for further searches will not make
it crash. What does everybody else find? I got the impression that
maybe I was the only one getting the segfaults. Anyone?

Tom Barnes-Lawrence

reply via email to

[Prev in Thread] Current Thread [Next in Thread]