[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [GNUnet-developers] mysql database problem

From: eric haumant
Subject: RE: [GNUnet-developers] mysql database problem
Date: Fri, 4 Apr 2003 10:05:05 +0200


You were right, I've upgrading my mysql server to 4.0.12 and it works fine.
In fact mysql with gdbm is the two most powerfull (in insertion speed and
space use) database in gnunet.

I'm having several gnunetd running on the same machine and with the current
mysql implementation there can be only one gnunetd connection (because it
connects to the same database with tables of the same name). 
This problem is naturally solved using all others database types because
their storage areas is different. To solve the problem I think we can make
as much databases as users, or we can add user identifier to table names
(the best way I think).


-----Message d'origine-----
De : Igor Wronsky [mailto:address@hidden
Envoye : jeudi 3 avril 2003 18:58
A : eric haumant
Cc : 'address@hidden'
Objet : Re: [GNUnet-developers] mysql database problem

On Thu, 3 Apr 2003, eric haumant wrote:

> I'm trying to use the mysql database type for gnunet. I've installed mysql
> (version : 3.23.49) on my Debian, I've make a user that has the same name
> my gnunetd user, a database named gnunet. I've make the .my.cnf file in
> home directory of my user (I tried login in and it works). But when
> gnunetd, it drops without any errors. I've hacked the code and found that
> call to mysql_real_connect drops gnunetd.
> Can anyone help me ?

Yes. Don't use mysql 3.23.49. That has a segv bug precisely with
the way that gnunetd connects to it. And let me stress that
its a bug of mysql, and not gnunetd. It can be solved by using
either earlier or later version of mysql.

Personally I think it especially unfortunate that 3.23.49 is
the version bundled with several distros.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]