[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GNUnet-developers] autoconf error on GNUnet CVS

From: Glenn McGrath
Subject: Re: [GNUnet-developers] autoconf error on GNUnet CVS
Date: Wed, 28 May 2003 04:51:43 +1000

On Tue, 27 May 2003 11:05:42 +0200
eric haumant <address@hidden> wrote:

> Hello,
> I've downloaded the latest cvs version of GNUnet and tried to install
> it on a Debian system.
> I've installed autoconf 2.57 and automake 1.7 but when I run bootstrap
> it says :
> You should update your `aclocal.m4' by running aclocal.
> You should update your `aclocal.m4' by running aclocal.
> error: possibly undefined macro: AC_LIBTOOL_DLOPEN
>       If this token and others are legitimate, please use
>       m4_pattern_allow. See the Autoconf documentation.
> error: possibly undefined macro:
> AC_LIBLTDL_INSTALLABLE error: possibly undefined
> macro: AC_DISABLE_STATIC error: possibly undefined
> macro: AC_PROG_LIBTOOL error: possibly undefined
> macro: AC_LIB_LTDL autoreconf: /usr/local/bin/autoconf failed with
> exit status: 1
> What is the problem ?

Do you have libtool installed ?

Im having another go at the debian packages, i previously got stuck on a
libtool install problem the same as mentioned at

Basically, the that shipped with 0.5.4 is broken if you do
"make install DESTDIR=<path>", one solution is to run "autoreconf -if"
with a newer libtool installed, that will replace

Now that i know the problem the debs shouldnt be far away.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]