[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with sharing files

From: Christian Grothoff
Subject: Re: Problem with sharing files
Date: Sun, 26 Dec 2021 17:50:01 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.12.0


I looked into this a bit, but could not find it. What is known:

1) The client must be doing a datastore PUT or RESERVE operation (both
are possible), and expects the datastore to return a STATUS response
(type 94), but that never happens.

2) I checked, and on all code paths the datastore should generate a
STATUS for PUT/RESERVE requests. So I figured maybe it is blocked on
some other request, but also that does not seem to be the case from the
code logic. But, hard to be sure.

3) Some paths depend on the storage plugin being used (postgres, sqlite,
mysql, heap). It might help if you could (a) say which one you used, and
(b) tried with a different storage plugin so we can see if this is

4) I tried with 'gnunet-publish' on my system, which worked fine. Did
you try the CLI, or only gnunet-fs-gtk? It should not make a difference,
but diagnosing the issue might be easier if we can reproduce it with a CLI.

Last but not least, I did in the past have issues with the database if
it had gotten very big and slow. That's partially because of design
issues in FS, and partially because of naive usage of the database(s) --
depending on which backend you are using.  So another question here is:
how big is your database? I'd usually expect it to be empty if this is
you testing things for the first time, but if your peer was running for
a while, it might have grown to many gigabytes and may be really just
terribly slow...

My 2 cents


On 12/22/21 2:55 PM, TheJackiMonster wrote:
> Hey,
> I'm currently working on the implementation of file sharing via GNUnet-
> FS service in the messenger-gtk application. But only the callback from
> uploading gets called only once with 0/N bytes uploaded and after some
> time the following warning shows up multiple times:
>    ERROR Request 0x5590f0f01830 of type 94 at head of datastore queue
>    for more than 1 m
> I've also thought this would be caused by some implementation issue on
> application side. So I checked using cadet-gtk which worked in the past
> already (it fails similarly) and even gnunet-fs-gtk provides the same
> problem. The upload starts but it does not proceed.
> Maybe someone working on the datastore or FS service knows more details
> about this or how this could be fixed?
> Happy hacking
> Jacki

reply via email to

[Prev in Thread] Current Thread [Next in Thread]