[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU Robots needs old Guile

From: Joshua Judson Rosen
Subject: Re: GNU Robots needs old Guile
Date: Mon, 8 Feb 2021 03:33:49 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.7.0

On 3/1/20 7:41 PM, Peter Wiehe wrote:> Hi GNU Robots list,
> I tried GNU Robots 1.2.0 and when I ./configure, I get the error that it 
> needs Guile 1.8. But on my Xubuntu I have only Guile 2.0 and 2.2. I installed 
> 2.0 dev.
> I tried to get 1.8 from the Guile Git page but that doesn't work.


Thanks for your interest, and hopefully patience since it has taken a very long 
time for me to reply....

There is a fix for this in the GNU Robots git repository currently, along with 
many many other bugfixes,
so you should no longer need such an old version Guile in order to build and 
run GNU Robots.

It's taken a long time to get back to the point where I can say this, I'm 
hoping to make a new stable release
with all of these fixes at some point in the next couple of months (and 
possible another release not long after that,
depending on how quickly I can merge in all of the improvements that Matthew 
submitted this past summer).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]