gnustep-dev
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnustep-cvs] Commit Update


From: Fred Kiefer
Subject: Re: [Gnustep-cvs] Commit Update
Date: Sat, 14 Aug 2004 14:46:04 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040114

+2004-08-13  Quentin Mathe <address@hidden>
+ + * Source/NSComboBoxCell.m:
+       * Source/NSComboBox.m:
+       Fixed broken combo box behavior introduced June 17 with version 1.27,
+       which produced wrong tracking in the button cell and extra mouse down
+       call in the NSComboBox superclass. Now the rewritten version is also
+ documented. + Also now -[GSComboWindow deselectItemAtIndex:] still produces a
+       -[GSComboWindow tableViewSelectionDidChange:] call but the chain is
+       stopped in -[GSComboWindow validateSelection] by the _locationSelection
+       variable, then -[NSComboBoxCell selectItemAtIndex:] is not anymore
+       wrongly called.
+       

Hi Quentin,

the actual contents of your change look fine to me at first glance. But the style of the ChangeLog needs improvement. In GNUstep we try to comment on the place and type of the actual changes and less on the reasons for the change and the still open issues (though they are needed to be listed sometimes). So your change could have looked like this:

        * Source/NSComboBox.m (-mouseDown:): Reverted use of variable
        clicked and renamed it to buttonClicked.
        * Source/NSComboBox.m: (-runModalPopUpWithComboBoxCell:) removed
        unneeded tableview setDelegate: call and remove observer for
        notifications from the current window.
        And so on...

Also there is no reason, why you had to add trackMouse:inRect:ofView:untilMouseUp: to the NSComboBoxCell header. This method is already declared in NSCell and we normally don't add overwritten methods to the header. The only reason would be to place the new documentation there, but this you put into the source file (And again I agree that this is the better place to put it).

Cheers
Fred




reply via email to

[Prev in Thread] Current Thread [Next in Thread]