[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] add gnutls_certificate_find_issuer

From: Simon Josefsson
Subject: Re: [PATCH] add gnutls_certificate_find_issuer
Date: Thu, 21 Feb 2008 22:56:05 +0100

On 21 feb 2008, at 18.32, Nikos Mavrogiannopoulos wrote:

Simon Josefsson wrote:

Seems useful. But what about using *_get_* instead of *_export_* in the function names? The few functions with _export_ in the names appear to
extract (i.e. copy) the values, but these functions appear to just
export pointers. There is also the confusion with export restrictions,
which some function names with _export_ in them refer to.  So _get_
might be more appropriate.  What do you think?
Hm.  Some function names use *_trust* rather than *_cas* too.  Should
gnutls_certificate_export_x509_cas be gnutls_certificate_get_x509_trust? There is a lack of plural there, and we already have one function with
_cas in it -- gnutls_certificate_free_cas -- so maybe
gnutls_certificate_get_x509_cas is simpler.

Yes, I also think it is better. I've renamed the _export_ -> _get_. However it seems we already have a release with the _export_ names...

Thanks. I don't think renaming the functions should be a problem even if we have a (devel) release - we only guarantee ABI compatibility between stable releases. Otherwise we can't make any mistakes on the devel branch, which seems unfair.

Generally, these considerations should probably be documented better though, right now they are just my opinions.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]