[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-dev] Working towards 3.10 release

From: Hal Murray
Subject: Re: [gpsd-dev] Working towards 3.10 release
Date: Fri, 08 Nov 2013 18:00:32 -0800

> Those are scons state files.  If I try to delete them from with scons,
> various postconditions fail and havoc ensues.  (One version of the  havoc
> was the carnivorous config bug.)  Sorry, I did try. 

OK.  For now, I'll just follow scons distclean with rm -r .sco*

I think this tangle is reasonably important.  Here is my story from this 

I was working on a system that was missing chrpath.  A good error message 
would be nice, but I recognized the problem.  A good error/warning message 
would be doubly nice if I had the library installed and it was going to test 
the wrong one.

I installed chrpath
scons check didn't work
scons -c, scons, scons check didn't work
rm -r .sco*, scons, scons check worked 


scons check still gives me 3 errors:

Regression test FAILED: 3 errors in 87 tests total (0 not found).
The following test Failed:

That's on Fedora.  I tried current, ancient, and pre-beta systems.  All get 
the same error.

These are my opinions.  I hate spam.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]