[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-dev] Device detach/attach & client bug?

From: Ferry Huberts
Subject: Re: [gpsd-dev] Device detach/attach & client bug?
Date: Thu, 23 Jan 2014 15:39:37 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.2.0

On 23/01/14 11:42, Ferry Huberts wrote:
Hi guys,

I have a strange problem that I think is a bug:
- USB gps device, a ublox EVK-5H (generic NMEA mode)
- the device is connected
- start gpsd
- start gpsmon
- see NMEA sentences flow
- detach device
- no more NMEA sentences
- attach device
- still no NMEA sentences

I have to start another gpsd client for the NMEA sentences to resume.

I can reproduce this 100%.

I have had no time yet to try another gps device but I'd like to ask if
others can reproduce this behaviour?

PS. I've tried to work around it (in my client code) by detecting device detach and attach and then reconnect to gpsd but that doesn't work.

Ferry Huberts

reply via email to

[Prev in Thread] Current Thread [Next in Thread]