[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-dev] Has anybody tried the SiRF S4?

From: Michael Tatarinov
Subject: Re: [gpsd-dev] Has anybody tried the SiRF S4?
Date: Wed, 12 Mar 2014 11:23:56 +0400


2014-03-12 10:30 GMT+04:00, Hal Murray <address@hidden>:
> I saw a comment about them someplace so I ordered one.
> I'm testing a GlobalSat BU-353S4  (USB)
> So far, not great.
> It's a bit more sensitive than a SiRF 3 in a similar location.
> Playing with gpsmon, I can't get it to change baud rate.
> It often ends up non-responsive:
>   Neither gpsmon nor gpsd will talk to it.
>   Power cycle fixes things.
> I think I saw a similar problem when trying to switch from SiRF binary to
> It starts at 4800, NMEA.
> gpsmon can switch to SiRF mode.
> gpsd/ntpd/shm only gets 1/2 to 3/4 of the samples.
> Is SiRF mode, gpsmon says:
>   Grumph, now that I want to cut/paste, I can't get it to show the firmware
> version.
> Finally got one:
> ?^FGSD4e_4.0.4-P1_RPATCH.07-GS008-F-GPS-4R-1201128 01/12/2012 012
> In SiRF mode, I haven't seen any data in the the block in the lower-right,
> DGPS Status.
> I assume part/most of the problem is due to the lower baud rate.

SiRF 3 is broken. I opened PR
As workaround I wrote patch

> How does gpsmon decide to poll for the Firmware Version?
> Is there any key I can use to get it to try again?
> (Are there other packet types only polled occasionally?)

gpsmon requests FW version on initialization.
You can try to send FW request (0x84 0x00) via gpsmon 'x' command.

> In SiRF mode, the lower left block of gpsmon says Measured Tracker, Packet
> Type 4.
> The two rightmost column are labeled "?" and "SF".
> What do they mean?
> With a SiRF 3, I see occasionally Ts in the ? column and nothing in the SF
> column.
> With the SiRF 4, I see similar Ts and some 2 digit numbers in the SF column,
> but they get rewritten to blanks frequently and, after a delay, filled in
> again slowly.  (Seems like more than a single packet type.)

'T' in column '?'  means that bit 1 in state field Message ID 0x04 sets.
for SiRF docs:
"Bit 1 set means that the phase relationship between the I and Q
samples is being tracked. When this bit is cleared, the carrier phase
measurements on this channel are invalid."

SF is SubFrame (50bps data). In this column prints PRN for which
subframe data were obtained.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]