[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-dev] Device detach/attach & client bug?

From: Eric S. Raymond
Subject: Re: [gpsd-dev] Device detach/attach & client bug?
Date: Wed, 20 Aug 2014 22:08:15 -0400
User-agent: Mutt/1.5.21 (2010-09-15)

Ferry Huberts <address@hidden>:
> On 23/01/14 11:42, Ferry Huberts wrote:
> >Hi guys,
> >
> >I have a strange problem that I think is a bug:
> >- USB gps device, a ublox EVK-5H (generic NMEA mode)
> >- the device is connected
> >- start gpsd
> >- start gpsmon
> >- see NMEA sentences flow
> >- detach device
> >- no more NMEA sentences
> >- attach device
> >- still no NMEA sentences
> >
> >
> >I have to start another gpsd client for the NMEA sentences to resume.
> >
> >I can reproduce this 100%.
> >
> >I have had no time yet to try another gps device but I'd like to ask if
> >others can reproduce this behaviour?
> >
> PS. I've tried to work around it (in my client code) by detecting
> device detach and attach and then reconnect to gpsd but that doesn't
> work.

For this to work, you need to have the udev rules installed to send
notifications to the gpsd control pipe on USB attach/detach, and you
have to pass gpsd the argument at startup that says to listen to 
the same control pipe the udev scripts are talking to.

Perhaps you have missed one or more of these steps?
                <a href="";>Eric S. Raymond</a>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]