[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gpsd-dev] Missing PPS in gpsmon

From: Hal Murray
Subject: [gpsd-dev] Missing PPS in gpsmon
Date: Sun, 01 Feb 2015 22:28:32 -0800

I just did a bisect.  I tried that a while ago, but it didn't work because I 
was only testing the gpsmon half of the pair.  I'm pretty sure the problem is 
in gpsd.

To start with, I ran gpsd with -G and looked at the wire and didn't see any PPS 
from gpsd.

This time bisecting, I used both gpsd and gpsmon built in the same directory.  
I didn't carefully check from that other system at each step, but the several 
spot-checks that I did agreed.

git says:

88a0c062d32d34138cccdf199db522538840bd09 is the first bad commit
commit 88a0c062d32d34138cccdf199db522538840bd09
Author: Eric S. Raymond <address@hidden>
Date:   Sat Aug 23 18:35:20 2014 -0400

    PPS is no kinger marked unstable/experimental.

:100644 100644 e412916812cb927690bea8bfb389285656feaa1b 
2b6140ba14ce09c2794c9b1b2aa0648ae3fe76ee M      NEWS
:100644 100644 9bed147b17854016d321867bad868b5bbb97d476 
e4aea4ceec918d788c41e6397603dea043342baa M      TODO
:100644 100644 3e9bd804dbef59112e930efce0b05671f4e6945c 
a8c31b182d92161c986c606e34b65eb2e5c52580 M      gps.h
:100644 100644 70d2f1109a27ceb5949ba349f71fa7e8a8e2642e 
dbda5a833f8c894ee98a2cd1f729b3171fc459b6 M      gpsd.c
:100644 100644 64c13e0a1dc4fdd116311ab7876b11ec4bd16e7d 
582f946d2c7c53836e2ee1cd6c8fc168ef17e648 M      gpsd_json.c
:100644 100644 3c809e59cf63ffd9d4e625df3f3588550b49989d 
7772ab693c868ebadc7175a4b4d2806bdd4d87c0 M      gpsd_json.xml
:100644 100644 bbaf8957c28c5cb5fdf077d422ecf08e2e2f72bd 
567cf2549f1455e5798bd4894d7dc35f163ccfd1 M      libgps_core.c
:100644 100644 4c6f14ed4cea9af765e19fc8ec99854631471580 
7c87c3e60367f20eebb01f3efc49727d7fbe3f56 M      shared_json.c
:040000 040000 3f5d281cfc3512947221e14f1af01f9f815f178b 
2047c71a9b34a0b8798a920f39b626282543b5b6 M      test

These are my opinions.  I hate spam.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]