[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-dev] gpsd Build Error "stdatomic.h" Not Found; Ubuntu 14.04 +

From: Gr Hudy
Subject: Re: [gpsd-dev] gpsd Build Error "stdatomic.h" Not Found; Ubuntu 14.04 + ARM Cortex A-15
Date: Thu, 05 Jul 2018 13:50:54 -0600

Thanks for the reply, Gary!

To answer a few of your questions in one swell foop, some choices are forced by 
nVidia. The Tegra Jetson Tk1 has custom drivers for the nVidia hardware, and 
nVidia does not support versions of Ubuntu later than 14.04 on this device. 
Also, the version of GCC provided by nVidia is 4.8, which is required to build 
some of the nVidia components. I installed GCC 6.4 because gpsd explicitly 
calls gcc-6 (and g++-6) in the scons script. I only tried gcc-5 to see if it 
would resolve the problem, but of course since scons explicitly calls gcc-6, 
that was rather pointless on my part.

 It's possible that my issue is related to the default gcc-4.8 include 
directories being used rather than the gcc-6 includes. I am looking into that 
UPDATE: Meh. It _was_ using cpp-4.8, and reading the 4.8 include directories. I 
fixed that, and still get the same error when using the gcc-6 include 

I have attached the output of scons as gpsd_scons.log . Also, I have included 
more information than you probably want about the machine environment as 

>> fyi, I am writing a driver that reads GPS information from a TCP
>> socket instead of a serial port;
>Why?  gpsd already does that, several different ways.
You're right. I posted before actually getting into the gpsd code proper, and 
later discovered that capability. I will definitely take advantage of that. 
Thanks for the tip!

With that in mind, I still have a bit of work to do; the INS we use is not 
mainstream, and has a proprietary binary format I will need to massage into the 
proper form. Then I will need to implement code in our existing INS server to 
feed properly formatted messages to gpsd as a TCP device . No rest for the 


----- Original message -----
From: "Gary E. Miller" <address@hidden>
To: address@hidden
Subject: Re: [gpsd-dev] gpsd Build Error "stdatomic.h" Not Found; Ubuntu 14.04 
+ ARM Cortex A-15
Date: Thu, 5 Jul 2018 10:49:55 -0700

Yo Gr!

On Tue, 03 Jul 2018 16:13:08 -0600
Gr Hudy <address@hidden> wrote:

> arm-linux-gnueabihf-gcc -pthread -o -c
> -fno-strict- aliasing -fPIC -DNDEBUG -g -fwrapv -O2 -Wall
> -Wstrict-prototypes - DHAVE_SYS_TIMEPPS_H=1 -I/usr/include/python2.7
> gpsclient.cIn file included from gpsclient.c:12:0: compiler.h:71:27:
> fatal error: stdatomic.h: No such file or directory #include
> <stdatomic.h>

stdatomic.h is part of gcc, and required by C11.  You must have a copy.

> Earlier in the same invocation, scons reported that stdatomic.h WAS
> available:
> Checking if compiler supplies __STDC_NO_ATOMICS__... no
> Checking for C header file stdatomic.h... yes

So you do have stdatomic.h.  Where is that file?  Must be a gcc config

Can you post the entire build file?

> Building the exact same gpsd-3.17 archive on my Ubuntu 16.04 X86-64
> machine builds flawlessly.

So why do you want to use old and crufty Ubuntu 14?

> I've tried building it on the Tegra with both GCC 6.4 and GCC 5.5
> (using update-alternatives) and get the same error.

Why do you want to use old gcc?

> Once it has failed, it won't build, but gets a different error (can't
> find pthreads).

Can't say anything about that, no details....

> Running scons -c followed by scons sconsclean doesn't
> clean things up: the build fails with completely different errors.

Yeah, known issue.  Best to just wipe the source tree and start over.

> fyi, I am writing a driver that reads GPS information from a TCP
> socket instead of a serial port;

Why?  gpsd already does that, several different ways.

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703
        address@hidden  Tel:+1 541 382 8588

            Veritas liberabit vos. -- Quid est veritas?
    "If you can’t measure it, you can’t improve it." - Lord Kelvin
Email had 1 attachment:
+ Attachment2
  1k (application/pgp-signature)

Attachment: gpsd_scons.log
Description: Text Data

Attachment: Jetson_Tk1_info.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]