[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: spurious install of ${prefix}/include/gps.h

From: Greg Troxel
Subject: Re: spurious install of ${prefix}/include/gps.h
Date: Thu, 05 Aug 2021 10:55:33 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (berkeley-unix)

"Gary E. Miller" <> writes:

> Yo Greg!
>> So it looks like somehow the install rule for ${prefix}/include/gps.h
>> got added to the build target.
> Yes,  these lines:
> headerinstall = [env.Install(installdir('includedir'), x)
>                  for x in ("include/libgpsmm.h", "include/gps.h")]
> Change gps.h to gpsX.h, and then build works fine!  Of course then
> the install fails.

I can confirm that changing gps.h to gpsX.h avoids this install rule
getting wrongly added to the build target (and yes the actual install
fails as you say).

> I found this worked for me instead:
> headerinstall = []
> headerinstall.append(Command(installdir('includedir') + "/include/gps.h",
>                              "include/gps.h", Copy("$TARGET", "$SOURCE")))
> headerinstall.append(Command(installdir('includedir') + "/include/libgpsmm.h",
>                              "include/libgpsmm.h", Copy("$TARGET", 
> "$SOURCE")))
> Does that work for you?

Interesting - that seems like sort of the same thing, but with an
explicit target location.

With that change, the erroneous build-time install was not provoked.

I think that has an extra include, as includedir is already
$prefix/include.  But I'll check that again more carefully.

I tried again without the /include and it still provoked the bug.

I'll have a look at scons sources a bit more.  It seems that it must
have some logic to notice -I in CPPFLAGS and promote an install rule to

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]