[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] GPSD Client Connected to Remote GPSD - Unrecognized req

From: Joshua Quesenberry
Subject: Re: [gpsd-users] GPSD Client Connected to Remote GPSD - Unrecognized request "" when running gpsmon
Date: Tue, 5 Jun 2018 18:46:13 -0400

As mentioned in the original post, I've tried using gpsmon and cgps, both of 
which were installed fresh using apt-get. The command being run on the client 

sudo /usr/sbin/gpsd -N -n -D 2 -F /var/run/gpsd.sock gpsd://

So isn't this the same situation as mentioned in the other post I listed? What 
you called master/slave?


Josh Q

-----Original Message-----
From: gpsd-users [mailto:address@hidden On Behalf Of Gary E. Miller
Sent: Tuesday, June 5, 2018 4:16 PM
To: address@hidden
Subject: Re: [gpsd-users] GPSD Client Connected to Remote GPSD - Unrecognized 
request "" when running gpsmon

Yo Joshua!

On Tue, 5 Jun 2018 08:39:21 -0400
"Joshua Quesenberry" <address@hidden> wrote:

> Correct me if I'm wrong, but shouldn't the server side be the only 
> part of this that requires the -G option?


> I have tried setting the -G
> on the client side, but it seemed to have no effect on the problem at 
> hand.

I'm surprised -G on a client is not a fatal error.  And what are your client 

> Server side was running with the command: sudo /usr/sbin/gpsd -N -G -n 
> -D 2 -F /var/run/gpsd.sock /dev/ttyUSB0

Why do you use -F and specify a device?  That will confuse things.

> My 2nd email showed this output on the server side, which indicates 
> that the client connected correctly and that the -G was in place and
> working:


> gpsd:CLIENT: <= client(0): ?\x0a
> gpsd:ERROR: ERROR response: {"class":"ERROR","message":"Unrecognized
> request ''"}\x0d\x0a gpsd:CLIENT: => client(0):
> {"class":"ERROR","message":"Unrecognized request ''"}\x0d\x0a
> gpsd:CLIENT: <= client(0): WATCH={"enable":true,"json":true};\x0a
> gpsd:CLIENT: => client(0): =

What client is that?  What gpsd version?  Clearly the client is broken.

> This email string seems to be pointing out a similar issue to what I'm 
> seeing:

Yeah, you can ignore that error.  It only affect master/slave gpsd when you 
start gps this way:  ./gpsd -N -D 5 gpsd://pizwcam.local

It has been fixed, but not in git head yet.  Since you are NOT running 
master/slave gpsd it will not affect you.

> My version appears to be 3.15, so I'm behind so I'm behind a little,

Yup, nothing we can do about old gpsd code you got elsewhere.

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703
        address@hidden  Tel:+1 541 382 8588

            Veritas liberabit vos. -- Quid est veritas?
    "If you can’t measure it, you can’t improve it." - Lord Kelvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]