[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Reg: Procedure for sending commands to gpsd over control socket.

From: Gary E. Miller
Subject: Re: Reg: Procedure for sending commands to gpsd over control socket.
Date: Thu, 6 Feb 2020 16:57:55 -0800


On Thu, 6 Feb 2020 12:41:54 +0530
RAJESH DASARI <address@hidden> wrote:

> We are using Trimble Acutime 360 TSIP GPS device in our linux  machine
> and it is connected to /dev/ttyS5 .

Cool, I have a Trimble RES SMT 360 for testing.  It is very picky about
the line format: 8O1
> I am starting the gpsd with the below command.
> /usr/sbin/gpsd -F /var/run/gpsd/gpsd.sock -n -N -D 15 /dev/ttyS5

I'm guess you also need "-f 8O1"

> I am trying to reset the GPS device with the control socket, for that

Odd.  I suspect the reason no one else answered, is that no one else
ever tried that.  Never occrued to me to try that.  But it should work.

> i have below script.

What doc let you to beleive that might work?

> GPS_time_req = b'!/dev/ttyS5=\x10\x25\x10\x03\n'

Odd, that does not look like any control string I've seen before...

> sending "212f6465762f74747953353d102510030a"
> encoded bytes  b'212f6465762f74747953353d102510030a'
> number of bytes  6
> data bytes  b'ERROR\n'

No surprise with your odd GPS_time_req string.
> Please find the attached file for the output from the gpsd when the
> above script is executed.  I tried sending different control packets
> to GPS device over the control socket but i am getting ERROR response
> always.

You cut off the log jsut as things were getting interesting.  There
was this:

gpsd:INFO: control socket connect on fd 8
gpsd:CLIENT: <= control(8): 212f6465762f74747953353d102510030a

It looks like your wacky string, complete with /dev/ttyS5, is being
sent to the GPS.  So maybe you just need to send a valid TSIP message
instead of your thing.

> Could you guys please let me know , is sending the commands to the gps
> device over control socket is supported ? if it not supported could
> you suggest any other way.  If it is supported could you please let me
> know the exact procedure.

It does not look like your procedure, but your control string is
the problem.

> I also tried sending the command the command directly to the device
> like echo -ne '\x10\x25\x10\x03' > /dev/ttyS5 but i didn't notice any
> reset logs on gpsd side to notify that gpsd is actually rebooting.

You can't output to ttyS5 is gpsd has it open.  If you can send to
ttyS5, you gotta have the correct speed and framing set first.

Also: '\x10\x25\x10\x03'.  x25 is not a valid message for newer Trimble.

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703
        address@hidden  Tel:+1 541 382 8588

            Veritas liberabit vos. -- Quid est veritas?
    "If you can't measure it, you can't improve it." - Lord Kelvin

Attachment: pgpLeJKlKphvk.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]