[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Only one client at a time (Debian, Raspbian)

From: Carles Pina i Estany
Subject: Re: Only one client at a time (Debian, Raspbian)
Date: Thu, 29 Jul 2021 23:41:51 +0200
User-agent: Mutt/1.10.1 (2018-07-13)

Hi Gary,

On Jul/29/2021, Gary E. Miller wrote:

> > I have now:
> > pi@raspberrypi:~ $ lsb_release -a
> > No LSB modules are available.
> > Distributor ID:     Raspbian
> > Description:        Raspbian GNU/Linux 10 (buster)
> > Release:    10
> > Codename:   buster
> I don't know what that is, and I don't care, too many distros to keep
> in my head.

:-) I understand, I thought that someone via Google/searcher future
might land here if searching with "Raspbian".

> > pi@raspberrypi:~ $ gpsd -V
> > gpsd: 3.20 (revision 3.20)
> Almost 2 years old.  known CVE, and will fail on 23 October 2021.

That's good to know, thanks!

> > # Other options you want to pass to gpsd
> "-n" is recommended there.
> > Then I connect the eTrex, I answer "No" for the "USB Mass Storage".
> Odd, then it sends NMEA?  What device does it show up as?  Clearly the
> hotplug is finding it.

I don't know what does the device send over the wire. The first line of
gpsmon says: "tcp://localhost:2947          Garmin Serial binary>"

> > And I get the NMEA strings doing "telnet 10110" (or
> > localhost...) and in the file.
> gpspipe could do that, in a lisghtly different manner.


> > Quick question if you don't mind: off the top of your head: do you
> > expect "Garmin GLO 2" device to work? I think that it's this one:
> >
> It says it does Bluetooth.  So it should work.  Except Bluetooth and
> gpsd together are fragile.

In my experience: "Bluetooth and * together are fragile". I hope (I'll
get my hands to this device on Wednesday next week, it's from a
colleague) that the USB connection also works (I have the manual and it
says that it has USB, I hope that the USB is for more than just

> > I'm new in all this world and I don't know how often things "just
> > work" (like a USB memory stick, in a standard way) or if they are very
> > specific to each device.
> Total lack of standardization in the GPS/GNSS receiver market.  A mess.
> Common devices work with gpsd because someone beats them into submission.
> > > I can't speak to the Debian package,  that is not from us.  
> > 
> > I updated gpsd Debian package to a newer version solved the problem
> > that I had (but I might have new problems! - after 10 or 20 min it
> > seems to sometimes just stop. I haven't done more testing yet).
> Add the "-n" option.  That forces gpsd to stay alive.

Thanks, doing it!

> > > New one on me.  Why use it?  
> > 
> > Ideally I would like gpsd to get the positions from the eTrex 30x
> > (whatever the on-wire protocol between gpsd and eTrex use) and then I
> > would like gpsd to:
> > -Save NMEAs to a file
> $ gpspipe -r > nmea.log
> > -Make NMEAs available over a TCP port
> "-G" option makes gpsd available on port 2947.

Thanks to OpenCPN having gpsd support and gpspipe: I could live without
kplex I think.

> > My understanding is that gpsd cannot do this.
> Not mine.

As said: I'm a newbie here. Happy to discover ways to do things.

> > I could connect two cgps after upgrading gpsd to a newer version than
> > what I had in Debian Buster (3.17 to 3.20)
> So, problem solved.
> > > 3.17 is ancient.  3.23 is to be releassed bext week.  

I need to use this setup until mid September (before the October

I will read the changelog and probably try to update from 3.20 to 3.22.

Thanks for all your advise,

Carles Pina i Estany

reply via email to

[Prev in Thread] Current Thread [Next in Thread]