[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[groff] Wierd font troubles

From: Dale Snell
Subject: [groff] Wierd font troubles
Date: Sun, 24 Mar 2019 13:24:09 -0700

Hi folks,

I just updated my computer to Fedora 29, and downloaded the latest version
of groff (1.22.4).  When I ran configure, it couldn't find the URW++
fonts.  Turned out I hadn't installed them.  D'oh!  Installed them, but
configure still couldn't find them.  I added the --with-urw-fonts-dir
option, but configure _still_ couldn't find them.  It took me some digging
(and pulling out what little hair I have left), but I found a couple of

    1)  URW++ has changed their file names to something human-readable,
instead of the nigh-password-worthy names they used to use.

    2)  URW++ no longer ships *.pfb files in their base35 fonts package.
Insead, they ship *.otf, *.afm, and *.t1 files.

configure looks in the urw-base35 fonts directory
("/usr/share/fonts/urw-base35" in Fedora) for "a010013l.pfb", which is now
"URWGothic-Book.pfb", to determine if the URW++ fonts are there.
Naturally, since the file didn't exist, it decided that there weren't any
fonts to install.  Thinking I could work around the problem, I used
FontForge to create .pfb files out of the .otf files.  Then I created
symbolic links to the apropriate old-style file names and ran configure.
Success!  Huzzah!

Alas, it was too soon to cheer.  When I ran make, BuildFoundries couldn't
build the groff fonts, and I don't know why.  The error message is:

    "BuildFoundries: warning: line 77: Failed to create groff font 'U-AB'
by running afmtodit"

where the line number increments by one for each groff font it can't build.

At this point I'm lost.  I am not a Perl programmer, so I don't know what
BuildFoundries is actually doing.  There is probably something very simple
going worng, but I don't know where to look.

Anyway, I gave up on groff installing the fonts automatically and used
Peter Schaffter's "" script.  Worked like a charm (thanks
Peter!).  So I installed several other typeface families (Linux Libertine
and TeX Gyre, among others).  All was well, or so I thought.

I did some work on a project file and ran it through groff (via pdfmom) to
build a PDF.  It seemed to have worked until I looked more closely.  Much
to my surprise, the ASCII single-quote character "'" which is supposed to
be rendered as a typographic single-quote, was still coming out as a
typewriter single-quote.  I tried changing font families and found
something very odd.  The fonts that groff installed work as expected.  The
ones I installed have the problem.  I have no idea why.  I can work around
the problem by adding a ".tr '\[cq]" line to the source file.  Still, I'd
like to know where things went wrong so that I can fix it.  Does anyone
have any suggestions?  Right now I have no idea where to start looking.


P.S.  What's a .t1 file?  My google-fu failed me; all I could find was a
reference to "male MRI" files.  Funny, I didn't know that MRI files had
gender.  At least, nobody said anything about it when my MRIs were taken.

"And finally, _thinking_ is an exercise to which all too few brains are
accustomed."  --E.E. "Doc" Smith, _First Lensman_

reply via email to

[Prev in Thread] Current Thread [Next in Thread]