[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[groff] Weird font troubles, redux

From: Dale Snell
Subject: [groff] Weird font troubles, redux
Date: Sat, 6 Apr 2019 12:00:48 -0700

Hi all,

You may remember my earlier posting regarding troubles I was having with
installing fonts for Groff.  For the most part, things have worked out well
enough.  However, there is still one problem that's hanging on, and that's
the refusal of Groff to properly replace an input typewriter apostrophe
with a typographic single quote.  I came up with a workaround, namely
putting a ".tr '\[cq]" request in my source files.  It kept bothering me
though, since it shouldn't be needed.  I kept trying to think of where the
problem could be coming from, without much success.  Yesterday, though, it
occured to me to change the command I use to build my PDFs, and bingo! it

Some background:  I normally use the MOM macro set; I really like it.  To
that end, I've taken to using the pdfmom wrapper to build my PDFs.

    "pdfmom -k -mdpm > outputfile.pdf"

where -mdpm refers to my personal Groff macros.  This has worked fine since
I started using it.  There is one error message that shows up, but it seems

    "troff:<linnum>: can't transparently output node at top
    where <linnum> is the line number of the MOM .START macro.

When I added the .tr request, I saw eight (always eight) of the following

    "troff:<linnum>: can't translate ''' to special
character 'cq' in transparent throughput"

Again, <linnum> is the location of the .START macro.  I changed my Groff
command string to

    "pdfroff -k -mdpm -mom -mpdfmark --no-toc >

and removed the .tr request.  Lo and behold, everything worked the way it
should.  Plus there are no error messages, which makes me happy.

I don't know why pdfroff works and pdfmom doesn't, but I'll leave that to
folks who understand those programs.  I felt that I should let folks know
what was going on, in case anyone besides me was tinkering with this.  (I'm
reminded of what some of my coworkers used to say when they needed to test
some software:  "Give it to Dale, he can break anything!"  Too true, alas.)


"And finally, _thinking_ is an exercise to which all too few brains are
accustomed."  --E.E. "Doc" Smith, _First Lensman_

reply via email to

[Prev in Thread] Current Thread [Next in Thread]