[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Font path issue

From: Peter Schaffter
Subject: Font path issue
Date: Fri, 19 Aug 2022 20:05:02 -0400
User-agent: Mutt/1.9.4 (2018-02-28)

In this post, "system" means groff/current/font/ and "local" means

After implementing Robert G's advice that the contents of the system
/devps 'download' file be copied into the 'download' file in the local
/devps 'download', I decided to explore the matter further by
building the local /devps and /devpdf from scratch.  I emptied the
two directories of all files and created a test file:

  .sp |1i
  .ps 20
  .vs 24
  .ft TR
  € (unicode)
  \[eu] \\[eu]
  \[Eu] \\[Eu]
  The quick brown fox jumps over the lazy dog.
  alpha beta gamma delta

Without explicitly setting GROFF_FONT_PATH and with both
local directories empty,
  groff -Tps -ke test >
built the file without complaining, but with upright Greek glyphs
instead of the expected slanted ones.  When I tried
  groff -Tpdf -ke test > test.pdf
groff produced an error Failed to open font 'TR' 
I tried again using the U-TR font, which is unique to gropdf, but
got the same error Failed to open font 'U-TR' 

According to the groff documentation, groff is supposed to search
both the system and local /devps and /devpdf font directories (plus
any given to '-F' at the command line), however it is not; TR and
U-TR are both present in the system /devpdf and should have been
picked up.

With both local directories still empty, I explicitly set
  export GROFF_FONT_PATH=/usr/local/share/groff/current/font/
and ran the -Tps and -Tpdf tests again.  Bingo.  The .ps file had
the expected slanted Greek glyphs and groff didn't complain about
not finding TR with -Tpdf.

It seems that Robert G's suggestion fixed his issue without
addressing the problem, which is that the system /devps and /devpdf
font directories are not being read by default.  There's no need
for the system 'download' contents to be copied over to the local
'download'.  What's required is explicitly pointing GROFF_FONT_PATH
to the system /devps and /devpdf font directories.

Is this a bug, or is it something that needs to be documented?  I'm
running a build; perhaps it's already been corrected?

Peter Schaffter

reply via email to

[Prev in Thread] Current Thread [Next in Thread]