[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: normal vs. rescue mode commands

From: Yoshinori K. Okuji
Subject: Re: normal vs. rescue mode commands
Date: Wed, 9 Jun 2004 13:19:34 +0200
User-agent: KMail/1.5.3

On Sunday 06 June 2004 12:55, Tomas Ebenlendr wrote:
> > 1. Generate two versions for each loader from the same source code.
> >
> > This case compiles the same source code twice to generate two
> > different loaders for rescue mode and normal mode. Basically, the
> > version for rescue mode would be a subset of the version for normal
> > mode. This makes redundant binary code, but the maintainability is
> > not very bad.
> This looks like best solution for me, also the 'normal' mode loader
> may depend on 'rescue' mode loader and use some of its functions.
> This looks like most 'clean' way. If we want that users won't be
> confused by 2 modules doing the same, we can add 'automatic module
> load support' which will load modules-normal_mode_extensions of
> loaded loaders to normal mode.

Ok. As others seem to have no opinion, let's go in this way.

Then, how about the naming convention? We need to have a standard way to 
distinguish between normal mode loaders and rescue mode loaders by file 
names. That is why I prefixed loaders with '_'. But I don't think an 
underscore is so good.

And, at the same time, I'd like to make all filenames fit into the 
DOS-style (8.3 filenames), so that we don't need to use VFAT on FAT 
filesystems. I think this is better, because Microsoft claims that they 
have a software patent about the long filename extension... *sigh*

What do you think?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]