[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GRUB 1.90 is released

From: Vernon Mauery
Subject: Re: GRUB 1.90 is released
Date: Wed, 10 Aug 2005 09:06:32 -0700
User-agent: Debian Thunderbird 1.0.2 (X11/20050331)

Yoshinori K. Okuji wrote:
> I'm happy to announce the release of GRUB 1.90. This is the first of
> our prereleases leading up to GRUB 2.0. We encourage you to try it, as
> we have done a significant amount of work towards GRUB 2. Note that this 
> release is mainly for developers who are willing to contribute to our 
> project. If you need a working solution immediately, you'd better to stick to 
> GRUB Legacy at the moment.

I am seeing unaligned pointer messages when I use grub2 on /dev/hda2.  If I 
type 'root (hd0,2)', I get 'unaligned pointer 0x7ff94' and if I type 'insmod 
(hd0,2)/boot/grub/mulitboot.mod', I get 'unaligned pointer 0x7ff64'.

I downloaded the source, built it and installed it on my hard drive to test it 
out.  I had an unused partition that contains a fork of my live system, so I 
figured I could put grub2 on that.  That partition was hda3 (hd0,2).  So I ran 
grub-install /dev/hda3 and that went okay.  The files showed up in the right 
spot in /boot/grub.  Then I ran grub-setup "(hd0,2)" which also went fine.  I 
tried booting the image in bochs and qemu using /dev/hda as the drive for the 
emulated machine, chainloading from grub-legacy on (hd0) to grub2 on (hd0,2).  
I get the grub prompt and all looks fine until I try to do something 
interesting.  Then I got the above messages.  I tried running on the actual 
harware rather than the emulator, but that gave the same messages, so I figured 
I should report them.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]