[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compiling GRUB 1.93 on OpenBSD

From: Marcos Latas
Subject: Re: compiling GRUB 1.93 on OpenBSD
Date: Wed, 19 Apr 2006 21:00:54 +0100
User-agent: Mail/News (X11/20060316)

Christian Laursen wrote:
Marcos Latas <address@hidden> writes:

I have been trying to compile GRUB 1.93 on an OpenBSD machine to
create a port for it.

When I run ./configure the following message appears:

checking for __lzo_init_v2 in -llzo2... no
checking for __lzo_init_v2 in -llzo... no
checking for __lzo_init2 in -llzo... no
configure: error: LZO library version 1.02 or later is required

Try the following command which works for me on FreeBSD:

BUILD_LDFLAGS=-L/usr/local/lib BUILD_CFLAGS=-I/usr/local/include ./configure

Remember to use gmake to build afterwards.

Thank you very much for the tip. I tried the following:

./configure CFLAGS=-I/usr/local/include

(I omited the LDFLAGS path because it seems to be correct)

It now stops here:

checking for objcopy... objcopy
checking whether objcopy works for absolute addresses... no
configure: error: GRUB requires a working absolute objcopy; upgrade your binutils

The file INSTALL mentions that GRUB requires GNU binutils or
later. I have binutils 2.15!

Any thoughts?

Thank you.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]