[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Failed to configure/make under Cygwin

From: Michele Montagni
Subject: Failed to configure/make under Cygwin
Date: Mon, 21 Aug 2006 11:04:26 +0200

I've tried compiling GRUB 1.94 in Cygwin under Windows 2000, but "configure" fails with the following messages:

 checking whether objcopy works for absolute addresses... no
configure: error: GRUB requires a working absolute objcopy; upgrade your binutils

My Cygwin is up-to-date as of today, thus the 'binutils'
package has no later version available. This is the version
information I get by using the commands "ld -v" and "objcopy -V":

 GNU version 2.17.50 20060709

I also downloaded, recompiled and installed the latest version of 'binutils', but the result did not change.
Notice that the same error is obtained while trying to "configure" the old, legacy GRUB version 0.97 .

Any ideas ?

Michele Montagni
via Sabotino 16
21100 Varese - Italy
phone: +39(0332)23.83.87
fax:      +39(0332)23.45.72
cell.:     +39(349)10.14.550    

reply via email to

[Prev in Thread] Current Thread [Next in Thread]