grub-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: NF4 and GRUB 0.97 not working - err 16, 18, 25


From: Jeroen Dekkers
Subject: Re: NF4 and GRUB 0.97 not working - err 16, 18, 25
Date: Mon, 28 Aug 2006 11:33:39 +0200
User-agent: Wanderlust/2.14.0 (Africa) SEMI/1.14.6 (Maruoka) FLIM/1.14.8 (Shij┼Ź) APEL/10.6 Emacs/22.0.50 (x86_64-pc-linux-gnu) MULE/5.0 (SAKAKI)

At Mon, 28 Aug 2006 11:05:03 +0300 (EEST),
Jan Wagner wrote:
> 
> Hi,
> 
> got an odd problem, GRUB 0.95 and 0.97 mysteriously refuse to boot beyond
> stage 1.5 on an nForce4 chipsetted mobo (Asus A8N-SLI Deluxe).
> 
> I've tried several parallel ATA disks (40GB, 120GB, 250GB), and also
> using a /boot partition at the start of the disk instead of just a single
> / plus swap, but to no avail.
> 
> When I move the exactly same test disks created on the A8N-SLI PC to
> different PCs (tried 2), they boot just perfect on those, with GRUB menu
> and all.
> 
> Even when installing Fedora Core 5 or Debian 3.1 on the A8N-SLI PC, the
> entire setup process completes fine, but upon reboot grub gives
> alternatively errors 16, 18 or 25.
> 
> Wiping the beginning of the disk with dd if=/dev/zero for a few blocks,
> then reinstalling e.g. FC5, the problem still persists.
> 
> So on the A8N-SLI Deluxe apparently no matter what, GRUB gets stuck on
> stage 1.5, no menu.
> 
> Any ideas?
> 
> I already did update-grub, grub-install /dev/hda --recheck, after
> booting with a recovery CD and chrooting to /dev/hda. Grub appears to
> install itself just fine, but booting still gives those errors.
> 
> Any thoughts on what to try next?
> 
> Some grub info (though I'm not sure if this is GRUB config issue since the
> same disk will boot to grub menu properly on a different PC...):
> 
> ------
> /boot/grub$ cat device.map
> (fd0)   /dev/fd0
> (hd0)   /dev/hda
> (hd1)   /dev/sda
> (hd2)   /dev/sdb
> (hd3)   /dev/sdc
> (hd4)   /dev/sdd

I've got the same motherbord and I don't have problems with it. I have
only SATA disks however. Are you sure the BIOS actually boots hda and
not sda? And that the above mapping is correct? It might be possible
that sda is hd0 and hda is hd4. An easy way to find is to remove the
SATA disks and see whether it works.

Jeroen Dekkers




reply via email to

[Prev in Thread] Current Thread [Next in Thread]