[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: NF4 and GRUB 0.97 not working - err 16, 18, 25

From: Jan Wagner
Subject: Re: NF4 and GRUB 0.97 not working - err 16, 18, 25
Date: Wed, 30 Aug 2006 10:10:29 +0300 (EEST)

On Mon, 28 Aug 2006 address@hidden wrote:
> > When I move the exactly same test disks created on the A8N-SLI PC to
> > different PCs (tried 2), they boot just perfect on those, with GRUB menu
> > and all.
> >
> > Even when installing Fedora Core 5 or Debian 3.1 on the A8N-SLI PC, the
> > entire setup process completes fine, but upon reboot grub gives
> > alternatively errors 16, 18 or 25.
> >
> > Wiping the beginning of the disk with dd if=/dev/zero for a few blocks,
> > then reinstalling e.g. FC5, the problem still persists.
> >
> > So on the A8N-SLI Deluxe apparently no matter what, GRUB gets stuck on
> > stage 1.5, no menu.
> >
> > Any ideas?
> >
> > I already did update-grub, grub-install /dev/hda --recheck, after
> > booting with a recovery CD and chrooting to /dev/hda. Grub appears to
> > install itself just fine, but booting still gives those errors.
> >
> > Any thoughts on what to try next?
> >
> I've got the same motherbord and I don't have problems with it. I have
> only SATA disks however. Are you sure the BIOS actually boots hda and
> not sda? And that the above mapping is correct? It might be possible
> that sda is hd0 and hda is hd4. An easy way to find is to remove the
> SATA disks and see whether it works.

Tried that - with no SATA disks plugged in, ran Knoppix from CD, chrooted
the PATA system disk and did a 'grub-install /dev/hda --recheck', then
tried rebooting, still with no SATA, and mapping seems correct, but it
does not work.

Again errors 16 or 18, randomly, at every boot attempt. And again, the
same disk boots just fine in another PC.

Another strange thing is that I've one old 40GB PATA that was the old
system disk of this NF4, and LILO had been upgraded to GRUB,
and with this disk and its GRUB (0.95) booting works - not sure why since
GRUB, /+swap partition layout, are identical to my new
nonworking grub disks.

Maybe grub install over lilo behaves differently than grub install onto a
disk with initially no bootloader ??

(I might give QEMU a go, maybe there is some way to debug GRUB from
inside there...?)

 - Jan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]