[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: another regression on Efika

From: Jordi Mallach
Subject: Re: another regression on Efika
Date: Tue, 10 Jul 2007 12:04:44 +0200
User-agent: Mutt/1.5.16 (2007-06-11)


On Wed, Jul 04, 2007, Hollis said:
> This problem could be caused by firmware presenting an
> incorrect /memory/available property. I would instrument
> grub_available_iterate() and heap_init() to confirm.
> That property lists unclaimed areas of memory, which are free for us to
> use as heap. The memory used for firmware itself (including exception
> handlers at 0), and the memory used by the loaded ELF file (GRUB), are
> missing from /memory/available, so we know not to try to use those
> regions for the heap.
> If that is in fact the problem (which wouldn't surprise me given this
> particular firmware's track record), then we'll have to add some
> hardcoded hack particularly for Efika in grub_machine_init(), bypassing
> the more general code we have now.

I'm afraid there must be more to this.

The last version of GRUB which worked for me was Debian's 1.95-5, albeit
it wouldn't show a valid menu (but that was caused by another bug, more
or less fixed now). At that time, I could at least type in my
linux+initrd commands to make the laptop boot.

When the package was later on updated to a CVS snapshot of 20070505,
GRUB started dropping me to OF at boot time. On Saturday, Robert helped
me track this regression down to this same commit. After reverting and
regenerating grub, I'm happy to report that for the first time my
Powerbook G4 laptop was able to boot with me pressing no keys at all,
using GRUB.

In short, whatever is causing these crashes is not only an Efika issue.
I suspect Apple, or Apple powerbooks at least, are also affected. I got
Sjoerd to try this on his powerbook, and he confirms this fixes for him.
Paul also tried, with the same results. Not all the powerbooks are the
very same model, there are different model revisions involved.

The biggest issue now is that we all had to fix our generated
configurations, as grub-probe and update-grub won't cope with a that looks like this:

(hd)    /dev/hda

This is a minor issue that I can fix by hand, luckily.

Jordi Mallach <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]