[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using GRUB2 for booting from CD

From: Jeroen Dekkers
Subject: Re: Using GRUB2 for booting from CD
Date: Wed, 15 Aug 2007 11:24:15 +0200
User-agent: Wanderlust/2.14.0 (Africa) SEMI/1.14.6 (Maruoka) FLIM/1.14.8 (Shij┼Ź) APEL/10.7 Emacs/22.1 (x86_64-pc-linux-gnu) MULE/5.0 (SAKAKI)

At Mon, 13 Aug 2007 20:40:27 -0400,
Alex Roman wrote:
> OK, I've done the following in grub-emu...
> I have a map file that looks like this:
> (fd0) floppy.img
> (cd0) grub2-iso.iso
> grub2-iso.iso is an iso I generate using genisoimage (mkisofs). I can
> mount it just fine.
> floppy.img is a floppy image I generate... It contains grub, basically
> and a few modules.
> I run grub-emu -d grub2 -m mapfile -r fd0
> grub2 is my build directory.
> I tried ls (cd0)/ but that did not work. The iso9660_mount function is
> saying that it couldn't read the superblock.
> Then I saw on your (Marco) blog about the loopback command. So I tried
> it as follows:
> loopback cd1 (host)/path/to/grub2-iso.iso
> Now, ls (cd1)/ goes a bit further, it can read the superblock, but it
> says it couldn't find the magic "CD001". I printed the data it reads
> from the ISO and it's all 0's...
> Am I doing anything wrong from what you can see here? I'd like to know
> if it's something I'm doing wrong in my procedure or in my code...

Read what's in the file directly and compare it to what grub-emu
reads. If it reads something different than that's a bug in the
grub-emu or loopback code. 

Also don't forget about the possiblity that qemu might be buggy,
especially if you're using bios functions that aren't really used that
much. Testing on real hardware is really necessary sometimes.

And whether your code is wrong or not is very difficult to tell if you
don't post your code...

Jeroen Dekkers

reply via email to

[Prev in Thread] Current Thread [Next in Thread]