[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Testing on PowerMac G4

From: Pavel Roskin
Subject: Testing on PowerMac G4
Date: Mon, 31 Dec 2007 03:12:29 -0500
User-agent: Internet Messaging Program (IMP) H3 (4.1.4)


I have tried the current GRUB on a PowerMac G4 running Fedora 8.

If I follow the instructions at, I cannot load grubof.modules. If I do it directly from openfirmware, I get "CLAIM failed" message.

I tried adding grubof.modules to the OS selection menu in ofboot.b script installed by yaboot, so that grubof.modules is loaded like yaboot. That doesn't work either. In some cases, I would get the openfirmware prompt, in other cases, the menu would restart. It looks like the attempt to load grubof.modules makes openfirmware unstable.

I also tried loading kernel.elf created by the build process. It loads and shows the prompt. However, GRUB starts in the rescue mode, and I cannot do anything in that mode.

Pavel Roskin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]