[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: macbook EFI experiences

From: Isaac Dupree
Subject: Re: macbook EFI experiences
Date: Fri, 30 May 2008 12:06:24 -0400
User-agent: Thunderbird (X11/20080505)

Robert Millan wrote:
On Fri, May 30, 2008 at 10:42:02AM -0400, Isaac Dupree wrote:
okay, I just tried a few days ago's grub2 CVS without patches for i386 efi, because presumably if that doesn't work for me then nothing else will either (though it's possible that a working x86-64 would work better for this particular EFI firmware, I suppose)

Actually, I think it's better supported via grub-pc.  In BIOS we have a
workaround for the keyboard bug.  Was there any other kind of trouble?

No it's not. I can't use the keyboard on BIOS here, except sometimes for one single keystroke or more if I get lucky (true for linux CD booting, not just grub2); but the keyboard works fine on EFI and always has. (Or was that workaround you mentioned in grub2 introduced sometime in the last year, in which case I should upgrade my grub2-bios installation?)

In any case I want to help debug grub2 efi to at least specify what still doesn't work, (if anything), even if the keyboard issue is fixed for bios. Then the question becomes whether Ubuntu can survive being booted without the BIOS CSM enabled -- which I have yet to see, because I couldn't get elilo to work for me either. But that's not the bootloader's problem, right? (although ideally it would be able to find a way to -- optionally -- enable the CSM, but I don't think a way has been found yet to enable it at all?)

The other thing I noticed is, while running grub2-efi, the fan goes on to max speed/noisyness. (But grub2 isn't intended to be a huge fancy OS so there may be nothing reasonable to do about this.)

Sounds like a firmware bug (busy polling for keyboard input).  Does this
device have an AT keyboard?  Our keyboard driver has the same bug, too, but
at least we can fix it ;-)

I have no idea what kind of keyboard it is... I know there's a built-in keyboard that I'm typing on, but I can't find it with `sudo lshw`, I can't think of anywhere more thorough to look, and Apple's specs don't seem to say <>. Plugging in an Apple USB keyboard was no better than the built-in one.

P.S. the bios-bootloader-keyboard failure is a well known Apple firmware bug that they claim to have fixed but it didn't seem fixed to me after I installed their firmware update


reply via email to

[Prev in Thread] Current Thread [Next in Thread]