[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub2 usb stick boot error

From: Fulvio Scapin
Subject: Grub2 usb stick boot error
Date: Tue, 24 Jun 2008 00:05:23 +0200
User-agent: Thunderbird (X11/20080619)

I am having a problem using Grub2 to boot some bootable partition stored
on a usb stick.
Basically I am trying to fit several distros, all fat partitions made
bootable with syslinux, on a usb stick and use grub2 to select and boot
one of them.
I should say that I come across two distinct cases, one using a GPT
label and a much worse one employing the usual dos label.
First I tried the gpt label cause I didn't relish the idea of using
extended partitions. On a 8GB stick I create a BIOS Boot Partition,
marked it with parted, and grub embedded itself in it with no problem.
Then a second partition containing the configuration of grub, and
further on several partitions containing distros, all fat16 bootable
thanks to syslinux. I discovered, to my surprise, that grub allows me to
boot only the third and fouth partition, while anyone beyond the fourth
gives me boot error. I even created a fifth partition containing the
exact same files of the fourth, and while the fourth boots, the fifth
still doesn't.
Then, on another stick, a 4GB one, I tried with a dos label. This time,
after countless tries to get grub installed, and having succeeded, I
discover that I can't boot any partition, even when having just two
partitions, one with the configuration of grub and the other a bootable
fat16 fs with a distro.
I tried Grub legacy and it works fine. I tried chainloading Grub2 from
Grub Legacy, just to make an attempt, and still no luck booting from Grub2.
I have to specify the with booting one of the volumes I mean
chainloading syslinux on it, doing a "chainloader +1" on the volume.
The Grub 2 console works fine (it's brilliant by the way) but I can't
chainload anything (with the GPT restricted exception detailed above. )
I compiled and run grub2 (from cvs and from git) on a Gentoo system
running on a Macbook, and tested the sticks on 2 common x86 machines and
with qemu with the same results.
I figuratively beating my head against the wall, so any help or comment
would be greatly appreciated.


I suppose I could just use Grub Legacy, but I just like Grub 2
immensely, so I'll keep that solution as a last resort, or maybe
chainload Grub2 from Grub Legacy at least to use the shell.

Thanks in advance,
Fulvio Scapin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]