[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Fix warning in fs/xfs.c

From: Pavel Roskin
Subject: Re: [PATCH] Fix warning in fs/xfs.c
Date: Sun, 20 Jul 2008 16:28:05 -0400

On Sun, 2008-07-20 at 20:50 +0200, Marco Gerards wrote:
> Pavel Roskin <address@hidden> writes:
> > i4 and i8 are generally used by Linux XFS code to describe 32-bit and
> > 64-bit values if either can be used.  The "smallino" field was highly
> > misleading because it had to be negated.  It's the number of "big" (i8
> > or 64-bit) entries.  If it's 0, then the entries are "small".
> >
> > So it was natural to call it "i8count".  And once it was "i8count", it
> > was natural to call the first value "count".
> >
> > If you prefer another naming convention, let's rename the entries
> > according to it.  I was thinking having 2 32-bit integers "parent_hi"
> > and "parent_lo" or something like that.  Anyway, let's not use
> > "smallino" - "bigentries" would be better.
> What I suggest is that you pick the names yourself or from a standard,
> instead of from Linux code.

OK, I'll try to be more creative.

Pavel Roskin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]