[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub-efi x86_64 on macbook air?

From: step21
Subject: Re: grub-efi x86_64 on macbook air?
Date: Wed, 28 Jan 2009 21:23:19 +0100

On Wed, Jan 28, 2009 at 7:05 PM, Javier Martín <address@hidden> wrote:
> El mié, 28-01-2009 a las 18:30 +0100, step21 escribió:
>> On Wed, Jan 28, 2009 at 5:56 PM, Javier Martín <address@hidden> wrote:
>> > El mié, 28-01-2009 a las 17:42 +0100, step21 escribió:
>> >> Hey, while investigating possibilities on how it might be possible to
>> >> install/run something "wubi" like on macs (without having windows
>> >> installed) I ran into a couple of issues. I post here mainly in hope
>> >> that one of the folks that actually wrote the code for this or at
>> >> least have experience with it read this, cause most ppl on irc (while
>> >> being very helpful) seem to know more about the pure x86/bios/linux
>> >> side of things.
>> >>
>> >> Besides some (minor?) issues like that the command line
>> >> freezes/becomes unresponsive after a (relatively short) amount of time
>> >> and the fact that booting back to OS X (which everyone says should
>> >> work 100%) does not work at all (it complains that it can't find the
>> >> specified os x *efi, but it is there, and search correctly finds the
>> >> right drive) my biggest problem right now is the following:
>> >>
>> >> I got some kerne/initrd combo to boot (2.6.26 from debian lenny
>> >> netinstall iirc) but it gets to the language selection screen, first
>> >> thing you notice, the keyboard is dead. I supplied "init=/bin/sh" to
>> >> be able to read at least the last of the error messages. As it turns
>> >> out to me it seems that seemingly everything pci-related is
>> >> unavailable. Error messages are as follows:
>> >>
>> >> [time after boot]PCI No IRQ known for interrup pin C of device
>> >> 0000:00:1a.7. Please Try using pci=biosirq
>> >> [time after boot]ehci_hcd 0000:00:1a.7 Found HC with no IRQ. Check
>> >> BIOS/PCI 0000:00:1a.7 setup!
>> >> [time after boot]ehci_hcd 0000:00:1a.7 fail, -19
>> >> (of course time/device ids and pins (A-D) changed, but otherwise they
>> >> were the same I think)
>> >> I tried supplying pci=biosirq although I didn't think it would work,
>> >> and it didn't, or some solution for a similiar issue from the debian
>> >> wiki for the macbook (using a usb keyboard) which didn't work either.
>> >> The usb keyboard works for refit and grub, but not once booted into
>> >> linux. On some other wiki page it was suggested to supply "noapic
>> >> acpi=force" and maybe "irqpoll" which I tried in various combinations
>> >> without a change.
>> >>
>> >> The machine I use for testing this is a first generation macbook air.
>> >> Now while there are numerous reports about people running linux on it
>> >> (pretty well actually) by providing it with a legacy bios environment,
>> >> I didn't find a report about one running grub-efi on it successfully
>> >> to boot linux. The most relevant posts my searches come up with are my
>> >> own posts on the ubunutu forums.
>> >>
>> >> So, I'm not sure who is to blame here, or if it's maybe just my own
>> >> fault, but I decided that it would be nice to get the
>> >> opinion/solutions? of some ppl who might be more intimately familiar
>> >> with the workings of the mac boot firmware etc. and maybe know if this
>> >> actually has been tested and should work, or not.
>> >>
>> >> Thanks for an help in advance.
>> >
>> > Are you sure that Debian lenny supports booting from EFI? I'm quite
>> > literally talking out of my ass here, so I don't have a clue, but it
>> > seems that the kernel you're trying to boot is trying to use BIOS
>> > functionality. GRUB does _not_ include BIOS emulation, so that will
>> > certainly not work. In order for a Linux kernel to boot from EFI, you
>> > have to enable the switch in the pre-build kernel configuration.
>> >
>> > From my past knowledge (on my brother's Macbook), at least Ubuntu/x86
>> > kernels _do_ have the EFI switch enabled, so you might give it a try and
>> > check if that's what's going wrong.
>> >
>> > On the OS X and keyboard issues, I'm afraid I cannot help you. Perhaps
>> > our elders would be wiser?
>> >
>> > PS: you could try, however, to enable debug output when compiling your
>> > GRUB so that you could see if there was anything wrong when loading the
>> > file, like a hypothetical hfs.mod error (again, talking out of my
>> > non-talking orifices)
>> >
>> > _______________________________________________
>> > Grub-devel mailing list
>> > address@hidden
>> >
>> >
>> >
>> Well, I didn't check specifically, but afaik the kernel has it
>> enabled. I tried with an ubuntu kernel before which didn't even get
>> that far. (just loaded kernel/initrd on commandline, but after "boot"
>> nothing happened)
>> Yes, I know grub does not supply bios emulation, but maybe the kernel
>> just fails to recongize that it's supposed to use efi?
>> On compiling kernel and grub2: I couldn't get compiling grub2 to work
>> on os x, even with a seperate gnu gcc, then it failed on linking and
>> it seems there is no gnu version of ld available for os x. (people say
>> it just doesn't run) so I kinda gave up. Also, which applies also to
>> kernel compiling, currently this is the only machine that totally
>> belongs to myself. I might drob wubi or something on some windows box
>> nobody really uses, and hope ppl don't hate me too much for that, then
>> I could compile grub2/my own kernel where I know I have everything
>> enabled. Anything specific I should be aware of if I compile grub2
>> with debug support? Someone on irc mentioned invoking grub_set_env()
>> in grub_main() or something, is that right? I know that I can set
>> debug=all in grub.cfg, but most of the time the output is so mch it
>> just floods my whole screen ...
> No, sorry, I'm afraid you found the last element of the food chain here,
> so I just gave you whatever I could gather from past experience. As I
> said, the elders may be wiser. However, if you cannot boot an Ubuntu
> liveCD (which _did_ work for my Macbook), you might be better off asking
> about EFI and the Macbook Air in the Debian and Ubuntu forms, rather
> than the grub-devel list: maybe it's just a kernel switch you're
> missing, or you could try to disable the "quiet splash" switches and see
> what the kernel spits out, etc.
> _______________________________________________
> Grub-devel mailing list
> address@hidden

Yeah, sure thanks for that.
Just to close up on this: Booting from a livecd would work, but this
is both impratical (no built in cdrom for example, and not sure if
permanent settings would work) but mostly this would then use bios
emulation, meaning it would not use grub-efi at all.
This is not just about setting this up for me (if it was I'd just
create a 50 MB partition and install grub-pc onto it), but
investigating whether it is a viable boot method that might be
packageable into some kind of mac version of wubi. This excludes
anything that uses grub-pc as that would require a seperate partition
and therefore partitioning. (just wanted to make this clear, and
thanks again)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]