[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Help with Grub2

From: BandiPat
Subject: Help with Grub2
Date: Sat, 31 Jan 2009 23:32:53 -0500
User-agent: Thunderbird (X11/20081105)

Ok, I've poured over this for 2 days now, so find myself needing some expert help! Let me go over what I have done. I'll try to give as much details as possible. If you don't see it, just ask.

Compiled and installed grub2. Remove LILO from MBR. Ran grub-install /dev/sda. Run grub-setup /dev/sda. Ran update-grub to let it create a grub.cfg file. So far, so good and checking everything, it all looks great according to the instructions I have been able to find. By the way, I have done a lot of researching these past 2 days! That's how I came to find this mail list, but wanted to wait to finish my testing before using it.

Rebooted the computer which gave me the Welcome to Grub, then the grub rescue prompt. I tried several things there without any success. Here are some of the things I checked. Tried setting some things there, then boot, but no luck. Checked with the "set" command:

All looks good so far.  Tried "boot", got error:  no loaded kernel
Tried "insmod linux", got error: out of partition (I think this might be needed for the kernel with Zenwalk)

Did "ls", got (hd0) (hd0,1) (hd0,2) (hd0,3) (hd0,4)

Used "qemu -hda /dev/sda" once which corrupted my sda2 partition, so did a fresh install of Zenwalk. Upsetting, but no harm, no foul. Acted like it was working, but things moved so fast, it was booting before I could stop it. I thought it just tested, but didn't boot. That didn't seem to be the case. After the fresh install, used it again, but it went right back to the "grub rescue>" prompt.

Here's my provided grub.cfg:
# It is automatically generated by /usr/local/sbin/update-grub using templates
# from /usr/local/etc/grub.d and settings from /usr/local/etc/default/grub

### BEGIN /usr/local/etc/grub.d/00_header ###
set default=0
set timeout=5
set root=(hd0,2)
terminal console
### END /usr/local/etc/grub.d/00_header ###

### BEGIN /usr/local/etc/grub.d/10_hurd ###
### END /usr/local/etc/grub.d/10_hurd ###

### BEGIN /usr/local/etc/grub.d/10_linux ###
menuentry "GNU/Linux, linux" {
        linux   (hd0,2)/boot/vmlinuz- root=/dev/sda2 ro
menuentry "GNU/Linux, linux (single-user mode)" {
        linux   (hd0,2)/boot/vmlinuz- root=/dev/sda2 ro single
### END /usr/local/etc/grub.d/10_linux ###
Only thing I added to try was the "insmod linux" in the upper part. Here is my setup on the HD:

My head hurts, so I might have left something out. Just ask and I'll try to supply it. :-)

Ok, thanks in advance. Would love to figure this out and get it working. I'm sure it's just something small, something I'm overlooking, but I'm just not seeing it. After I get this running, I'll be writing a small manual to include in the Zenwalk package I've built as well as detailed instructions on our Wiki!! ;-)


       ---Zenwalk v5.4--Linux 2.6.27---
        Registered Linux User #225206
"Ever tried Zen computing?"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]