[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub.efi x86_64 on Apple 64bit efi models - status of testing

From: step21
Subject: Re: grub.efi x86_64 on Apple 64bit efi models - status of testing
Date: Mon, 9 Feb 2009 13:38:49 +0100

> -------------------------------
> Three specific issues are stopping useful testing -
> 1. Mac models from imac8,1 early 2008 are unable to boot grub.efi 64bit when 
> 4GB RAM is fitted.
>   Dropping to 2GB RAM enables grub.efi to boot and display grub.cfg  menu 
> with fully functional command line. This leads to the next problems -
> 2. The grub.efi chainloader command fails to load 
> /usr/standalone/i386/boot.efi, reporting ' error: cannot load image '
> 3. grub.efi successfully loads ubuntu x86 2.6.7-7 kernel ( or earlier debian 
> 2.6.26 ) using command line or menuentry, but the boot fails.
> After boot command, the boot screen goes to black and no further progress 
> seen,
> except in one case some garbled video indicating possible boot but failure to 
> init.

As I pointed out on the forums, the farthest I got with one kernel was
for it to show either a shell (with init=/bin/sh) or the debian lenny
install screen. All PCI and usb devices seemed to not work at all
though, so doesn't

> 4. Finally, there was a problem getting ubuntu 810 amd64 to complete 
> initialization after booting in earlier 32 bit grub.efi tests, and other 
> issues with accelerated graphics and keyboard. - Not yet the issue here.

The accelerated graphics from what I understand are a general issue
with EFI booting, not much grub can do about it for now. If I
understand it correctly, either grub would have to play a bigger part
in video initilization, or more likely, the accelerated graphics
drivers would have to be rewritten, not very likely I think.

Keyboard and usb in general is already an issue. For example the
keyboard in the air, and probably in all macs is connected through
usb, which so far seems to mean it for example does not work with a
new module calle "at_keyboard" which should support keymaps and other
nice stuff in the future. Before that we had a patch that solved a
loss of keyboard input after about 2 mins, for the normal keyboard
support. I assume the earlier one worked cause it relied more on
callbacks to the EFI subsystem to make the usb.

Maybe this sums it up a bit. Of  course, if any of the devs feel like
I misrepresented some facts, feel free to correct.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]