[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Split big and little endian BeFS and AtheFS

From: Robert Millan
Subject: Re: [PATCH] Split big and little endian BeFS and AtheFS
Date: Mon, 24 Aug 2009 01:09:25 +0200
User-agent: Mutt/1.5.18 (2008-05-17)

On Sun, Aug 23, 2009 at 01:04:30PM +0200, Vladimir 'phcoder' Serbinenko wrote:
> On Sun, Aug 23, 2009 at 12:40 PM, Robert Millan<address@hidden> wrote:
> > On Thu, Aug 20, 2009 at 06:16:24PM -0400, Pavel Roskin wrote:
> >> I don't think we should rename "byte_order" to "unused".  Just because
> >> we doesn't use it now to determine the endianess,
> >
> > Shouldn't we be checking for it?  (and error out if mismatch).
> This field is unstraightforward to use. We already have the same
> information from the magic (which is stored in native-endian). I feel
> like checking additional field will just lead to rejected FS
> especially if I don't get this field right. In other words I prefer to
> keep complexity to minimum especially in parts of code not used
> extensively.

As long as you're confident that we're discarding invalid FS reliably, no
problem with it.

Robert Millan

  The DRM opt-in fallacy: "Your data belongs to us. We will decide when (and
  how) you may access your data; but nobody's threatening your freedom: we
  still allow you to remove your data and not access it at all."

reply via email to

[Prev in Thread] Current Thread [Next in Thread]