[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[multiboot] abstractmbi, modules

From: Grégoire Sutre
Subject: [multiboot] abstractmbi, modules
Date: Thu, 14 Jan 2010 15:49:06 +0100
User-agent: Thunderbird (X11/20091027)


I made some tests with the people/phcoder/abstractmbi branch, but I'm a bit late reporting them... Better late than never I guess :-)

I compiled the branch and installed GRUB from Linux on a USB stick, and then booted my NetBSD box from the stick, with multiboot. It worked like a charm. :-)

Regarding the question (on irc) whether it also works with modules, it turns out that NetBSD/i386 kernel multiboot code lacks module support (in -current). Therefore, to test modules, I tried booting Xen 3.3 (with NetBSD as DOM0), with:

grub> multiboot (...)/xen.gz console=vga
grub> module (...)/netbsd-XEN3PAE_DOM0 console=pc
grub> boot

and I got an error "Panic on CPU0" from Xen (before booting DOM0). This is with the abstractmbi branch, I didn't try with GRUB trunk. There are some reports in the archives of grub-devel regarding problems with Xen 3.3, so maybe this is a known issue with GRUB. Note that with NetBSD's boot loader, which is also able to multiboot with modules, doing:

load /netbsd-XEN3PAE_DOM0 console=pc
multiboot /xen.gz console=vga

works fine.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]