[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Patch] [bug #26237] multiple problems with usb devices

From: Aleš Nesrsta
Subject: Re: [Patch] [bug #26237] multiple problems with usb devices
Date: Sat, 22 May 2010 01:46:57 +0200

Hi Vladimir,

I have some news - I made extensive testing and researching and I
discovered some things related to OHCI and generally to USB MS or USB

I tried to fix them and it looks like I was probably successful in some

- multiple LUNs related bug (meaning of value from device & coding into
- bulk transport toggling related bug - on devices with endpoints with
the same "low" nuber (e.g. 01 & 81)
- bug related to devices with max. packet size for control pipe 0 lower
than 64
- problem with one kind of OHCI BIOS legacy support maybe solved
- another bug - some devices hangs because of Bulk-only Mass Storage
Reset used during opening when it is not expected by device
- my OHCI done-head loop should not hang anymore - timeout was added
- "ls" should not hang anymore on USB MS device with not ready unit -
timeout was added in SCSI open unit ready loop
- experimentally added support for another subclasses of USB MS devices
(as all are SCSI based - it possibly should work, at least it is working
with one my device with subclass SFF-8070i - but I don't have another
devices to test)

In fact, all my USB MS devices are working now with grub2 with exception
of one camera which have not Bulk-Only but CBI protocol.

What I was not solved till now:
- Some devices are not working on UHCI
- If I connect some device and load uhci module, I cannot connect
another device without rebooting. On OHCI it is possible without
rebooting in this sequence:
        rmmod usbms
        rmmod ohci
        (unplug old device and plug new one)
        insmod ohci
        insmod usbms
- It looks like my OHCI is not properly reporting STALL state of pipe -
it is probably reason why done-head loop hanged if some problem happened
in communication.

I want to prepare patch and send it here but I cannot get actual bzr
code. I would want have it at least because grub_memalign problem is not
solved in last grub version wich I have (1.98) and I have to solve it by
some workarounds (maybe it is also reason why UHCI does not work
properly on my computer, I did not any workaround in its code yet).

I cannot get actual bzr code because of this error:
$ bzr get
bzr: ERROR: Not a branch:

I tried to found some advice in man bzr and forums but I was not
successful. It looks like problem is that there is really not existing
folder ".../r/.bzr/branch" (I found "branch-lock" and "repository" only)
- should I use some another address or some option ?
Do You have some experiences with such problem ?
Could You put me in right direction...?

(I tried to download CVS source code - it works - but it looks outdated.
I also tried register ssh public code and made access via ssh to
sftp://address@hidden/srv/bzr/grub - but I cannot login,
there is ssh debug message that it is not possible to find
authentication method...)

Best regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]