[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

UEFI Boot with Grub-Experimental

From: stephen
Subject: UEFI Boot with Grub-Experimental
Date: Wed, 30 Jun 2010 01:54:36 -0700
User-agent: RoundCube Webmail/0.3-beta

After having no luck using the grub-efi-amd64 package in ubuntu, or the grub trunk, I've started trying to compile my own grub and getting it to boot on a new Intel motherboard which supports EFI. I've not been able to get any output yet from the acutal linux kernel; usually the system will simply hang after the boot menu option is selected, or the 'boot' command is issued from the grub command line.

Currently the farthest I've gotten is using the grub command line and typing in the following commands:

insmod efi_gop # no impact on result
insmod ext2
insmod part_gpt

set root=(hd0,gpt3)
fakeroot # optional, no impact on result
linux /vmlinuz ro video=efifb noefi single # 'noefi' and 'video=efifb' have no impact on overall result
initrd /initrd.img

The output is:

error: no suitable mode found
booting however

And then nothing else happens. I've appended "no impact on result" on various things in the command(s) that I've tried that were suggestions, but had no visible result in the hang or the message.

I've also tried newreloc, but I don't think this has anything to do with relocations.

Any suggestions?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]