[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Big Endian fix patch

From: Lennart Sorensen
Subject: Re: Big Endian fix patch
Date: Wed, 28 Jul 2010 11:51:58 -0400
User-agent: Mutt/1.5.18 (2008-05-17)

On Wed, Jul 28, 2010 at 11:00:37AM -0400, Lennart Sorensen wrote:
> On Wed, Jul 28, 2010 at 04:51:24AM -0400, Doug Nazar wrote:
> > Ok, finally made some progress. Ran into several issues, some of them  
> > obviously QEMU/OpenBios that I'm not sure if GRUB should work around.  
> > With your patch the raid mostly worked, small problem with too many  
> > devices because OpenBios creates several aliases for some devices. Also  
> > I think you missed the endianess when setting the level.
> OK, no idea how I got by without that.  It is currently working for me.
> Weird.
> I only use raid1 of course, so that is all I tested with.
> > This patch includes the following:
> >
> > - Fix the ofdisk_hash system. We weren't making a copy of the devpath so  
> > never found the cached item again.
> Could this have anything to do with why I can't see disks without
> devaliases assigned?
> > - Extend the ofdisk_hash to cache the disk size
> > - Scan for a disk size using seek (probably want to set a different  
> > start size). Required for metadata 1.0 arrays
> > - Optimize checking of raid level
> > - If we find a duplicate disk (claims to be same index in the array),  
> > skip it or else level 0 arrays wont be found
> > - QEMU/OpenBios doesn't seem to like if the prev & name parameters of  
> > ieee1275_next_property are the same pointer which caused no devices to  
> > be found
> QEMU/openbios has many bugs unfortunately.  If I could make any sense
> of the code I would try to fix some of them, but I simply can't follow
> that code.
> > The issues that I came across which are in QEMU/OpenBios:
> >
> > - The rows are misreported. screen-#rows is set to 75 when in fact there  
> > are only 60 rows. Worked around using -prom-env parameter
> > - Aliases don't take into account the index (i.e. address@hidden). I ended 
> > up with
> >     disk /pci/pci-ata/ata-1/disk
> >     hd /pci/pci-ata/ata-1/disk
> >     ide0 /pci/pci-ata/ata-1/disk
> >     ide1 /pci/mac-io/ata-3/disk
> >     ide2 /pci/mac-io/ata-3/disk
> >
> > when ide1 should be address@hidden and ide2 should be address@hidden
> > - boot command hangs when passed wrong disk or used from boot-command.  
> > Worked around by using load & go
> >
> > Things do work, and fixing QEMU/OpenBios is a bit further down the  
> > rabbit hole than I want to go. ;-)

Well the patch didn't break anything for me, but didn't seem to change
anything either.  So so far not a problem.

I was wondering a bit why tab completion for ls doesn't work on md 1.x devices. 
 If I do:

ls (md/0<tab>, I get
ls (md/0,
Well since I don't have any partitions, that doesn't help anything).

Also if I do:
ls (md/0)/<tab> I get nothing.  ls (md/0)/ does work, but the tab
completion refuses to believe it could work.  I miss tab completition. :)

Len Sorensen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]