[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Using grub on fuloong 6004

From: David Kuehling
Subject: Using grub on fuloong 6004
Date: Sat, 23 Jul 2011 13:11:04 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.2 (gnu/linux)


I've been unsuccessful so far with making grub work on my Fuloong 6004
box.  What I tried first wast the 'grub-yeeloong' package of debian
squeeze, building a grub.elf as described in the debian-yeeloong wiki
[1] (i.e. grub-mkimage --format=mipsel-yeeloong-elf ...)

The resulting grub.elf only shows a black screen when loaded from pmon,
and doesn't show any reactions.

Then I found some mailinglist threads that refer to
--format=mipsel-fuloong-elf (i.e. not "yeeloong").  Only the bzr trunk
seems to have support for that.  Tried this thursday's trunk version,
and built my image using

  sudo grub-mkimage  --config=/boot/grub.elf.conf \
     --output=/boot/grub3.elf --format=mipsel-fuloong-elf --verbose \
      ata part_msdos ext2 reboot halt lspci ohci usbtest usbms linux \
      fat xfs part_gpt multiboot2 minicmd configfile gcry_md5 hashsum

My /boot/grub.elf.conf reads

  set root=ata0,msdos1
  set prefix=($root)/grub

My /boot partition is /dev/sda (ext3).

however, this image now blanks the screen and shortly after reboots the
fuloong when loaded from the pmon menu.

Am I doing anything wrong?  Is Fuloong support known to be not (fully)



GnuPG public key:
Fingerprint: B17A DC95 D293 657B 4205  D016 7DEF 5323 C174 7D40

Attachment: pgpH1Loy9tjTn.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]