[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using grub on fuloong 6004

From: Vladimir 'φ-coder/phcoder' Serbinenko
Subject: Re: Using grub on fuloong 6004
Date: Thu, 29 Sep 2011 10:58:08 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110831 Iceowl/1.0b2 Icedove/3.1.13

On 25.07.2011 23:46, David Kuehling wrote:
>>>>>> "Vladimir" == Vladimir 'φ-coder/phcoder' Serbinenko <address@hidden> 
>>>>>> writes:
> [..]
>>> - keyoard still not working.  Tried plugging in after grub startup,
>>> but doesn't help (for grub-diy.elf i had to shortly plug in the
>>> keyboard to select it in pmon, so mayb that doesn't count).  Also
>>> mouse was disconnected.
>> I've been unable to recreate. Keyboard worked fine both when GRUB
>> loaded as ELF and when GRUB is firmware. I've uploaded them to
>> and
>> do you see any messages if you set debug=usb,ohci ?
> If I use your grub.elf, it just prints something like 'Press Esc to skip
> loading grub.cfg from hard-disk', then waits a few seconds, then the
> screen gets black and the hdd led light flickers and it's trying to boot
> something without success.
That's because you have a separate /boot and the version I uploaded
looks only for /boot/grub/grub.cfg, not /grub/grub.cfg and in case of
failure it retries. So other than keyboard not working it works as expected.
>   Pressing Esc on the keyboard doesn not have
> any observable effect.
> I tried with 4 different keyboards with no success.  
That's weird given that code works with several keyboards here and also
on yeeloong.
> With my own grub.elf, adding debug=usb,ohci to my /boot/grub/grub.cfg
> does not produce any output, but maybe it's just hidden by the menu
> showing up?  Anything that I can do to be sure to see messages?
> Redirect them to the serial port?
As a possibility. Or add an interruptible sleep at the end
> Just to be sure, I now updated my grub.cfg to contain
>   insmod ohci
>   insmod usb
>   insmod usb_keyboard
>   [..]
>   terminal_input usb_keyboard
> Which was generated from usr/local/etc/default/grub via the lines
>   GRUB_TERMINAL_INPUT=usb_keyboard
>   GRUB_PRELOAD_MODULES="ohci usb usb_keyboard"
> The debug= lines I added before insmod ohci (but of course it's gone
> after update-grub).
> In case it is of any help, I attach 'lspci -vv' and 'lsusb -vv' output.
Seems to be same as mine other than keyboard model, of course. In short,
I'm puzzled.
>>> - menu looks a little grabled (lots of '@' instead of border), but
>>> won't complain about that
>> It just means that no unifont was supplied
> Yeah, with my dm-crypt partitions, grub has no chance to access its
> fonts.  Moved them to /boot and added 
>   GRUB_FONT=/boot/grub/fonts/euro.pf2
> to my default/grub, now that part is fixed (I wonder why you don't copy
> fonts to /boot when you detect partitions unaccessible to grub in
> 00_header.  debian's grub.d/05_debian_theme applies such a handling to
> the splash images, copying them if neccessary).
Because we recommended a too small /boot/grub partition on PowerMacs in
the past.
> BTW the file is still misgenerated by grub-mkdevmap on
> loongson.  It writes 'hd0' where it should use 'ata0'.
doesn't matter as long as UUIDs are correct.
> cheers,
> David
> _______________________________________________
> Grub-devel mailing list
> address@hidden

Vladimir 'φ-coder/phcoder' Serbinenko

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]