[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: RAIDZ Support

From: Vladimir 'φ-coder/phcoder' Serbinenko
Subject: Re: RAIDZ Support
Date: Sat, 03 Mar 2012 22:08:54 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20120216 Icedove/8.0

On 06.02.2012 21:27, Richard Laager wrote:
I tried booting off a 3-disk raidz1 pool. By default, ZFS on Linux uses
a GPT label even for whole-disk pools. I've also tried overriding that
and putting the zpool directly on the 3 disks.

Either way, grub-probe / is happy. grub-install /dev/sda doesn't
complain (though grub-install /dev/sd[bc] fails). But when I try to
boot, GRUB says "error: no such device: 451dab4c40fdb4c1." (the GUID
obviously changed when I recreated the pool).

One way, prefix and root use "hd0, gpt1". The other way, they use "hd0".

What should I do to start debugging this?
I'd try testing with grub-fstest and checking the output of ls with different arguments
How can I enable the grub_dprintf() output?

Vladimir 'φ-coder/phcoder' Serbinenko

reply via email to

[Prev in Thread] Current Thread [Next in Thread]