[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] from bzr failed : error: expected source fi

From: Daniel Kahn Gillmor
Subject: from bzr failed : error: expected source file, required through AC_LIBSOURCES, not found
Date: Sun, 07 Apr 2013 00:04:08 -0400
User-agent: Notmuch/0.15.2 ( Emacs/23.4.1 (x86_64-pc-linux-gnu)

hi grub folk--

I'm trying to build grub from the current bzr head on a powerpc64 debian
unstable system.  I'm afraid i'm getting stuck right at the beginning,
as i try to autogen:

0 address@hidden:~/src/grub/grub$ ./ 
Importing unicode...
Importing libgcrypt...
Creating Makefile.tpl...
Running autogen...
Saving timestamps...
Running autoreconf...
autoreconf: Entering directory `.'
autoreconf: not using Gettext
autoreconf: running: aclocal -I m4
missing file grub-core/gnulib/getopt1.c error: expected source file, required through AC_LIBSOURCES, 
not found
m4/gnulib-comp.m4:100: gl_INIT is expanded from... the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: /usr/bin/autom4te failed with exit status: 1
autoreconf: aclocal failed with exit status: 1
1 address@hidden:~/src/grub/grub$ 

I don't know what this error means; i've got gnulib and the various
auto* packages installed:

0 address@hidden:~/src/grub/grub$ dpkg -l 'auto*' gnulib
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
ii  autoconf       2.69-1       all          automatic configure script builde
un  autoconf-archi <none>                    (no description available)
un  autoconf-doc   <none>                    (no description available)
un  autoconf2.13   <none>                    (no description available)
un  autofs         <none>                    (no description available)
ii  autogen        1:5.17.2-1   powerpc      automated text file generator
ii  automake       1:1.12.6-2   all          Tool for generating GNU Standards
un  automake1.10-d <none>                    (no description available)
un  automake1.12   <none>                    (no description available)
un  automake1.5    <none>                    (no description available)
un  automake1.6    <none>                    (no description available)
un  automake1.9    <none>                    (no description available)
un  automaken      <none>                    (no description available)
ii  autopoint  all          The autopoint program from GNU ge
ii  autotools-dev  20120608.1   all          Update infrastructure for config.
ii  gnulib         20120404+sta all          GNU Portability Library
0 address@hidden:~/src/grub/grub$ 

i've also tried it with automake 1:1.11.6-1 and autogen 1:5.12-0.1, and
i get the same error messages when doing ./ from a clean copy.

what am i missing?


Attachment: pgpbFhZfFxDww.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]