[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub2 boot root-on-zfs errors

From: Vladimir 'φ-coder/phcoder' Serbinenko
Subject: Re: grub2 boot root-on-zfs errors
Date: Sun, 10 Nov 2013 15:47:44 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20131005 Icedove/17.0.9

On 10.11.2013 11:41, Andrey Borzenkov wrote:
> В Sun, 10 Nov 2013 12:28:50 +0200
> Beeblebrox <address@hidden> пишет:
>>>> Did you rerun ./
>> I ran gmake clean and cleaned all conig**** folders, then re-started
>> from scratch.
> It would be more clean to start in new directory. If you build inside
> source tree, use "git clean -d -x -f" to remove everything not in GIT
> repo and start anew with
>>>> What is the value of your target_os ?
>> Build, host & target are all the same. I tried setting all 3 as
>> i386-freebsd for one of my runs, but that did not work.
>> Otherwise, I did not set it in the configure command, as I expect the
>> build should be able to identify the target on its own. Is this
>> incorrect?
> Try explicit --target i386-freebsd. It is always possible that
> autoconfiguration fails.
It shows that we can't rely on target_os for available linking formats.
Probably we should try different formats until we find one that works
like in attached patch
> _______________________________________________
> Grub-devel mailing list
> address@hidden

Attachment: link.diff
Description: Source code patch

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]