[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [RFC PATCH 0/3] grub powerpc64 little-endian enablement

From: Andrei Borzenkov
Subject: Re: [RFC PATCH 0/3] grub powerpc64 little-endian enablement
Date: Sun, 21 Sep 2014 17:58:44 +0400

В Thu, 28 Aug 2014 16:56:02 -0300
Paulo Flabiano Smorigo <address@hidden> пишет:

> From: Paulo Flabiano Smorigo <address@hidden>
> Hi,
> At the beginning of the year we provide a patchset that enabled GRUB for
> little-endian PowerPC. Our approach at the time was to build GRUB itself and
> its tools in 64-bit little-endian. One of the reasons of build in 64-bit is
> to avoid 32-bit dependencies in the distro and build a system entirely 64-bit.
> This patchset was not welcomed at the time because it would bring a
> high-maintainance-cost, without real gain since it could just be 
> cross-compiled.
> After that, Brent Baude, Vladmir (phcoder) and I started to work in a solution
> that would cross-compile but without 32-bit dependencies. This patchset is the
> result of this new approach. It's based on the work of Brent Baude, Vladimir
> (phcoder), and Tomohiro.
> It can be devided in two parts:
>   1) Skip libgcc dependency just for ppc64el (patch 1 and 2);
>   2) Check elf endianess and byteswap if necessary (patch 3);
> The result is GRUB itself in 32-bit BE and its tools in 64-bit LE. This 
> solution
> satisfies the needs of the distros. I tested it in three different distros, in
> both endianess and it's fine.

Unfortunately I'm still not able to boot this version on QEMU. I build
on openSUSE for three acrhs - ppc, ppc64, ppc64le. First two are OK and
boot successfully. Third one does not work - it ends up in exception. I
get initial GRUB greeting and that's all.

Same problem I got with Vladimir libgcc patch series.

It could be toolkit issue of course; but still it would need fixing
before we can merge it.

Could you help in debugging this issue? I have near to zero experience
with PPC; I can do what you tell me, but not much more.

I run it with

qemu-system-ppc64 -M pseries -cdrom /tmp/grub2-ppc64le.iso -boot d

Attached is screenshot of error.

Attachment: QEMU_022.png
Description: image/apple-ios-png

reply via email to

[Prev in Thread] Current Thread [Next in Thread]