grub-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AW: Grub2 EFI: compatibility with wimboot


From: jame88fane
Subject: AW: Grub2 EFI: compatibility with wimboot
Date: Wed, 20 Jun 2018 17:27:23 +0200

No it is windows UEFI 64bit on a UEFI 64bit platform
it doesn't matter anyway because even if I try to boot only Wimboot EFI from
Grub2 EFI without parameters I also get a blackscreen.

I mean:

menuentry "Windows 7" {
linux /boot/wimboot/wimboot
 }

I can't get linux16 to work in EFI, can I?

-----Urspr√ľngliche Nachricht-----
Von: Daniel Kiper <address@hidden> 
Gesendet: Mittwoch, 20. Juni 2018 12:42
An: address@hidden
Cc: 'Daniel Kiper' <address@hidden>; address@hidden
Betreff: Re: Grub2 EFI: compatibility with wimboot

On Fri, Jun 15, 2018 at 07:14:29PM +0200, address@hidden wrote:
> Okay,
> wimboot works in Grub2 Legacy for example:
>
> # Successfully boots
> menuentry "Windows 7" {
>       set ISOpath="/img/windows_7.iso"
>       loopback loop $ ISOpath
>       linux16 /boot/wimboot/wimboot
>       initrd16 \
>               newc:bootmgr:(loop)/bootmgr \
>               newc:bcd:(loop)/boot/bcd \
>               newc:boot.sdi:(loop)/boot/boot.sdi \
>               newc:boot.wim:(loop)/sources/boot.wim
> }
>
> Because I can not use linux16 in Grub2 EFI, I use only linux but this 
> creates a blackscreen (with the chaining it does not work either).
>
> I also asked the developers of wimboot they said grub2 could not load 
> EFI binarys directly.
> So I ask, is that the case?
>
> P.S.
> I found this maybe this helps:
> https://superuser.com/questions/1093986/boot-with-wimboot-a-windows-x6
> 4-imag
> e-on-uefi-32-bits

Wait, are you trying to run Windows UEFI x64 on UEFI x32 (to be precise
ia32) platform? It seems to me that such configs are not supported.
Additionally, paths above show that you are trying to use legacy BIOS stuff.
It will not run on UEFI platforms. I think that you should use more or less
something like that (+/- /amd64 part):
  - /amd64/boot/boot.sdi,
  - /amd64/efi/microsoft/boot/bcd,
  - /amd64/efi/boot/bootx64.efi
  - /amd64/winpe.wim.

So, more or less there is a chance that the issue is not related to GRUB2.

Daniel




reply via email to

[Prev in Thread] Current Thread [Next in Thread]