[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[CRYPTO-LUKS v1 00/19] Fixes and improvements for cryptodisks+luks2 and

From: Glenn Washburn
Subject: [CRYPTO-LUKS v1 00/19] Fixes and improvements for cryptodisks+luks2 and a few other things.
Date: Fri, 31 Jul 2020 07:01:41 -0500

I've changed the name of the patch series to make it more self-explanatory, but
still incremented the version number.  All of Patrick's suggestions have been
added in.  I've added 2 new patches, one suggested by Patrick for rename
cryptodisk's offset member to offset_sectors. And another to rename 'disk' to
'source' where appropriate in luks2.c.

Glenn Washburn (19):
  configure: Add Ubuntu dejavu font path.
  cryptodisk: Fix cipher IV mode 'plain64' always being set as 'plain'.
  cryptodisk: Incorrect calculation of start sector for grub_disk_read
    in grub_cryptodisk_read.
  cryptodisk: Add more verbosity when reading/writing cryptodisks.
  luks2: Add support for LUKS2 in (proc)/luks_script
  luks2: Rename source disk variabled named 'disk' to 'source' as in
  luks2: grub_cryptodisk_t->total_length is the max number of device
    native sectors.
  cryptodisk,luks: Allow special processing for comparing UUIDs.
  cryptodisk: Unregister cryptomount command when removing module.
  fs: Fix block lists not being able to address to end of disk
  cryptodisk: Properly handle non-512 byte sized sectors.
  cryptodisk: Rename total_length field in grub_cryptodisk_t to
  fs: Allow number of blocks in block list to be optional, where length
    will be defaulted to the length of the device.
  loopback: Add procfs entry 'loopbacks' to output configured loopback
  cryptodisk,luks2: Add header line to procfs entry and crypto and
    source device names.
  cryptodisk: Add a couple comments noting the usage of a couple fields
    in grub_cryptodisk_t as is done for grub_disk_t.
  luks2: Ensure that bit fields of grub_luks2_digest_t in
    luks2_parse_digest are initialized before returning.
  luks2: Fix use of incorrect index and some error messages.
  cryptodisk: Rename offset in grub_cryptodisk_t to offset_sectors to
    improve readability.                |   2 +-
 grub-core/disk/cryptodisk.c | 115 +++++++++++++++++++++++-------------
 grub-core/disk/geli.c       |   4 +-
 grub-core/disk/loopback.c   |  56 ++++++++++++++++++
 grub-core/disk/luks.c       |  29 +++------
 grub-core/disk/luks2.c      |  78 +++++++++++++-----------
 grub-core/kern/fs.c         |  10 +++-
 include/grub/cryptodisk.h   |  12 +++-
 include/grub/misc.h         |  21 +++++++
 9 files changed, 224 insertions(+), 103 deletions(-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]