[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [CRYPTO-LUKS v1 00/19] Fixes and improvements for cryptodisks+luks2

From: Patrick Steinhardt
Subject: Re: [CRYPTO-LUKS v1 00/19] Fixes and improvements for cryptodisks+luks2 and a few other things.
Date: Fri, 31 Jul 2020 17:59:26 +0200

On Fri, Jul 31, 2020 at 07:01:41AM -0500, Glenn Washburn wrote:
> I've changed the name of the patch series to make it more self-explanatory, 
> but
> still incremented the version number.  All of Patrick's suggestions have been
> added in.  I've added 2 new patches, one suggested by Patrick for rename
> cryptodisk's offset member to offset_sectors. And another to rename 'disk' to
> 'source' where appropriate in luks2.c.

Thanks for adressing my feedback! I'm not authoritative in this project
in any way, but I guess you'll have an easier time to get things merged
if you split this up into multiple patch series as there's unrelated
things you're doing here. E.g. something like the following might work
and make the review load a bit more manageable.

Font fix.

>   configure: Add Ubuntu dejavu font path.

Profcs changes:

>   loopback: Add procfs entry 'loopbacks' to output configured loopback
>     devices.
>   cryptodisk,luks2: Add header line to procfs entry and crypto and
>     source device names.

Cryptodisk related changes independent of LUKS:

>   cryptodisk: Fix cipher IV mode 'plain64' always being set as 'plain'.
>   cryptodisk: Incorrect calculation of start sector for grub_disk_read
>     in grub_cryptodisk_read.
>   cryptodisk: Add more verbosity when reading/writing cryptodisks.
>   cryptodisk: Rename offset in grub_cryptodisk_t to offset_sectors to
>     improve readability.
>   cryptodisk: Add a couple comments noting the usage of a couple fields
>     in grub_cryptodisk_t as is done for grub_disk_t.
>   cryptodisk: Unregister cryptomount command when removing module.
>   cryptodisk: Properly handle non-512 byte sized sectors.
>   cryptodisk: Rename total_length field in grub_cryptodisk_t to
>     total_sectors.

LUKS-specfic changes:

>   luks2: Rename source disk variabled named 'disk' to 'source' as in
>     luks.c.
>   luks2: Fix use of incorrect index and some error messages.
>   luks2: Ensure that bit fields of grub_luks2_digest_t in
>     luks2_parse_digest are initialized before returning.
>   luks2: Add support for LUKS2 in (proc)/luks_script
>   luks2: grub_cryptodisk_t->total_length is the max number of device
>     native sectors.
>   cryptodisk,luks: Allow special processing for comparing UUIDs.

fs-specific changes:

>   fs: Fix block lists not being able to address to end of disk
>     sometimes.
>   fs: Allow number of blocks in block list to be optional, where length
>     will be defaulted to the length of the device.


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]