[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v2 10/10] luks2: Rename source disk variabled named 'disk' to

From: Patrick Steinhardt
Subject: Re: [PATCH v2 10/10] luks2: Rename source disk variabled named 'disk' to 'source' as in luks.c.
Date: Fri, 23 Oct 2020 19:46:38 +0200

On Mon, Oct 19, 2020 at 11:27:12AM -0500, Glenn Washburn wrote:
> On Fri, 9 Oct 2020 12:00:47 +0200
> Patrick Steinhardt <> wrote:
> > On Sat, Oct 03, 2020 at 05:55:34PM -0500, Glenn Washburn wrote:
> > > This makes it more obvious to the reader that the disk referred to
> > > is the source disk, as opposed to say the disk holding the
> > > cryptodisk.
> > 
> > Hum. I'm not sure this actually helps readability, mostly because I
> > think that the distinction here is not that helpful in the context of
> > encryption or decryption of the device. In the end we are trying to
> > encrypt or decrypt the disk in order to create the new cryptodisk.
> > 
> > Anyway, I don't particularly care, so take this just as my two cents.
> > The patch itself looks good to me.
> > 
> > Patrick
> If I'm following you, you're saying that because encryption is
> reversible, `source` is not helpful because either plaintext or
> encrypted data can be the source depending on if you're encrypting or
> decrypting.

> In our case here, I think its intuitive to call the disk `source`
> because it is where the data is coming from and to distinguish it from
> the cryptodisk grub_disk_t. So its not called source because of the
> (encrypted) contents of the disk, as I think you're suggesting. I think
> this patch makes more sense in the context of some cryptodisk.c and
> luks.c code.
> Note that in grub_cryptodisk_scan_device_real in cryptodisk.c
> which calls luks2_recover_key the grub_disk_t passed is named `source`.
> And in in grub_cryptodisk_open, the parameter `disk` refers to a
> grub_disk_t that can be read to decrypt an associated encrypted
> grub_disk_t (ie. the cryptodisk grub_disk_t). The grub_cryptodisk_t
> associated in disk->data has a member named "source_disk" which points
> to the associated grub_disk_t and member "source" which is the name of
> the associated disk. In both luks2_decrypt_key and luks2_recover_key the
> grub_disk_t argument refers to the encrypted grub_disk_t which can be
> accessed as (unencrypted disk)->data->source_disk on the opened crypto
> disk. So I think its consistent with cryptodisk.c naming conventions to
> call the grub_disk_t argument "source". Also as the subject line says,
> this creates consistency with luks.c in its luks2_decrypt_key, which I
> suspect is named "source" for the reasons I outlined above. 
> I'm a little confused by "In the end we are trying to encrypt or
> decrypt the disk in order to create the new cryptodisk." Where does
> "encrypt" fit in to creating the new cryptodisk?

Let's just keep your patch if others think it helps readability. As I
said, I don't particularly care as to me the old naming was already
quite clear.


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]